0

I installed Debian a few weeks ago, and the last time I ran apt-get update, I think it updated something xorg/xserver, not sure.

Since then i get a black screen after boot. If I go into recovery mode I need to input the root password for maintenance, then I get a console.

I have an ATI Radeon HD 7800 and I installed the newest catalyst driver from the ATI website.

I checked /var/log/Xorg.0.log but couldn't find any errors (EE)

If I run startx, I just get a black screen, gdm3 gives me this error:(gdm3:1308): WARNING: Couldn't connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory.

What to do?

closed as unclear what you're asking by GAD3R, Tim Kennedy, lgeorget, countermode, Eric Renouf Mar 30 '17 at 12:37

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

1

You might have also updated other kernel modules related to your graphics chipset. Without knowing what you have done exactly it is hard to tell.

Here are some ideas

1. read logs while system is running

after your system seems to be booted, press CTRL + ALT + F1 to get tty1. Login and try reading your other error logs in /var/log/.

2. reinstall your video driver/module

I would also suggest reinstalling your graphics driver. This means you should install a command line browser like lynx or w3m then download and install your graphics driver/module.

http://support.amd.com/us/kbarticles/Pages/AMDCatalyst131ProprietaryLinuxGraphicsDriverReleaseNotes.aspx

After reading some logs and reinstalling your driver, you will at least have some insight on what to do next.

3. use fallback vesa driver

Another option is using the fallback vesa driver in your xorg.conf file. this will get the system up and running graphically on a basic level

  • I removed everything xorg/x11 with apt-get purge and installed it again. Now it works again. Thanks for your help! – Snowmobil May 6 '13 at 14:38
  • 1
    no problem, did reading the log help? or did you just reinstall X11 first off? – Nathan McCoy May 6 '13 at 14:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.