I am not new to Linux, but am new to creating my own virtual machine environment. I am using Linux to learn how to do penetration testing, and have been required to download lots of different software to do so. I added a virtual hard drive to my machine, partitioned it, and I can see that the space is available on my machine, as can be seen by running df -h(the hard disk is /dev/sda1 and has 75 GB):

    Filesystem      Size  Used Avail Use% Mounted on
    udev            2.4G     0  2.4G   0% /dev
    tmpfs           494M  1.1M  493M   1% /run
    /dev/sr0        4.9G  4.9G     0 100% /run/live/medium
    /dev/loop0      4.8G  4.8G     0 100% 
    tmpfs           2.5G   29M  2.4G   2% /run/live/overlay
    overlay         2.5G   29M  2.4G   2% /
    tmpfs           2.5G     0  2.5G   0% /dev/shm
    tmpfs           5.0M  4.0K  5.0M   1% /run/lock
    tmpfs           2.5G  4.0K  2.5G   1% /tmp
    tmpfs           494M   84K  494M   1% /run/user/1000
    /dev/sda1        79G  2.1M   75G   1% /media/user/191ce3f1-0e44-4e35-9b1d-dc5f45f65239

However, when I download things with apt-install, they download to the root filesystem, and there is apparently no way to avoid that. My filesystem only has 2.4 GB of space, but my hard disk has 79 GB. I cannot figure out how to allow the root filesystem to use the space on my hard disk. I do not fully understand the concept of mounting, and any attempts to mount the hard drive have been met with failure.

Output of mount:

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=2469632k,nr_inodes=617408,mode=755,inode64)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,noexec,relatime,size=505004k,mode=755,inode64)
/dev/sr0 on /run/live/medium type iso9660 (ro,noatime,nojoliet,check=s,map=n,blocksize=2048,iocharset=utf8)
/dev/loop0 on /run/live/rootfs/filesystem.squashfs type squashfs (ro,noatime,errors=continue)
tmpfs on /run/live/overlay type tmpfs (rw,noatime,mode=755,inode64)
overlay on / type overlay (rw,noatime,lowerdir=/run/live/rootfs/filesystem.squashfs/,upperdir=/run/live/overlay/rw,workdir=/run/live/overlay/work)
tmpfs on /usr/lib/live/mount type tmpfs (rw,nosuid,nodev,noexec,relatime,size=505004k,mode=755,inode64)
/dev/sr0 on /usr/lib/live/mount/medium type iso9660 (ro,noatime,nojoliet,check=s,map=n,blocksize=2048,iocharset=utf8)
/dev/loop0 on /usr/lib/live/mount/rootfs/filesystem.squashfs type squashfs (ro,noatime,errors=continue)
tmpfs on /usr/lib/live/mount/overlay type tmpfs (rw,noatime,mode=755,inode64)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,inode64)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k,inode64)
cgroup2 on /sys/fs/cgroup type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate,memory_recursiveprot)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=29,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=12225)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
tracefs on /sys/kernel/tracing type tracefs (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,nosuid,nodev,noexec,relatime)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
ramfs on /run/credentials/systemd-sysusers.service type ramfs (ro,nosuid,nodev,noexec,relatime,mode=700)
ramfs on /run/credentials/systemd-sysctl.service type ramfs (ro,nosuid,nodev,noexec,relatime,mode=700)
ramfs on /run/credentials/systemd-tmpfiles-setup-dev.service type ramfs (ro,nosuid,nodev,noexec,relatime,mode=700)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,relatime,inode64)
ramfs on /run/credentials/systemd-tmpfiles-setup.service type ramfs (ro,nosuid,nodev,noexec,relatime,mode=700)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=505000k,nr_inodes=126250,mode=700,uid=1000,gid=1000,inode64)
portal on /run/user/1000/doc type fuse.portal (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/dev/sda1 on /media/user/191ce3f1-0e44-4e35-9b1d-dc5f45f65239 type ext4 (rw,nosuid,nodev,relatime,errors=remount-ro,uhelper=udisks2)

Any help would be much appreciated. I have searched for hours and no one seems to answer the question I have. If I can explain anything more clearly, please let me know.

  • add the output of sudo mount to the question - preferably as text, not an image Jun 8 at 21:56
  • @roaima I apologize, I have never asked a question before. I have fixed it, Jun 8 at 22:20
  • Thank you for that
    – roaima
    Jun 8 at 22:32

1 Answer 1


You are apparently using a live system, i.e. something you could also boot from a CD/DVD. The idea behind these live images is that you only store/change a few files and most files will be unchanged. The overlay file system which seems to hold your root file system actually only holds changes to the otherwise read-only DVD image.

The changes you make to the root file system /, like installs etc. might even be gone after a reboot (both options are possible with overlay file systems).

If you want to keep the system installed, make updates, install software and store files I suggest to do a proper install of the system you require onto a full (virtual) root file system.

  • There should be a command within the Live system that allows you to install it on the target. Or just bite the bullet and install properly from the original media
    – roaima
    Jun 8 at 22:33
  • This helped me a lot. I fixed it. Thank you guys. It was a very simple problem but one that I didn't know I needed to solve. Jun 9 at 1:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .