0

I have a computer running KDE Neon. I recently attempted to repair grub using boot-repair since I kept getting the grub-rescue screen when booting. Now when I try to boot I see the grub Select Operating System screen but after selecting any option on the list, or clicking E or C to edit selection or open grub command line, the whole computer just freezes forcing me to hold the power button to turn it off.

Today, for a completely unrelated reason, I installed a fresh install of KDE Neon in VirtualBox on my (different) Windows computer. I was able to use the operating system after I installed it, but after I restarted the VM after using it for only a few minutes, the same exact issue happened where I saw the grub Select Operating System screen, and after selecting any option the VM froze. I also got a message from VirtualBox saying A critical error has occurred.

I have restarted the VM a few times before this and it worked fine. I'm not sure if this issue is in any way related to the issue with the other computer, but I thought i'd at least mention it. Also I'm more worried about fixing the other computer than the VM. If anyone knows how I can get my computer to boot again I'd appreciate the help. Thanks.

3
  • 1
    seems you're not alone forum.kde.org/viewtopic.php?f=309&t=176978 reddit.com/r/kdeneon/comments/z0vf4h/… - there's a temporary fix detailed in the reddit Jun 5, 2023 at 22:32
  • @JaromandaX Thanks! This worked perfectly in VirtualBox. I also tried the same thing with the other computer, and it was able to actually start booting, but then it stops. Clicking Esc during boot shows that the last line it always stops at just says "polkit.service". Also the computer is not frozen because I can still do Ctrl+Alt+F2 to enter tty2.
    – Ainyaku
    Jun 6, 2023 at 1:14
  • I was able to solve this second issue by simply reinstalling NVIDIA drivers using this post: unix.stackexchange.com/a/653334/573131
    – Ainyaku
    Jun 7, 2023 at 15:14

1 Answer 1

0

I was able to solve this issue on both the VM and computer using this temporary solution which was suggested by @Jaromanda X. Thanks!

The solution says to boot from a KDE Neon live USB, find the drive where KDE Neon is installed using fdisk -l, then run

sudo su
mount /dev/sda1 /mnt
mount --bind /dev /mnt/dev
mount --bind /dev/pts /mnt/dev/pts
mount --bind /sys /mnt/sys
mount --bind /proc /mnt/proc
chroot /mnt

and edit the file /etc/default/grub.d/99_breeze-grub.cfg by adding a # in front of the line that says GRUB_THEME=. Then run update-grub and the issue should be fixed until the next update.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .