0

I am trying to install any light-weight 32-bit Linux distribution on my Asus EeePc 1005HA. While booting from a USB I am able to use the keyboard in GRUB menu, but once past that the keyboard and touchpad are not working. External keyboard and mouse work fine. After browsing for a while I suspect the laptop is being recognized as a tablet and inputs are disabled, but I'm no expert and cannot confirm that. I've tried, Lubuntu 19, Puppy Linux 8 and 9, anitX 22, MX 23, Porteus 5. It's the same result in every system.

EDIT: After software updates were installed in Linux Lite 3.8 the internal keyboard started working.

3
  • 1
    Can you check the BIOS? Maybe you need to switch on the USB Legacy Support.
    – K-attila-
    May 30, 2023 at 12:06
  • USB Keyboard is working properly.
    – taliesinq
    May 31, 2023 at 12:57
  • That's why I told you, try to switch on the USB legacy support.
    – K-attila-
    May 31, 2023 at 13:52

1 Answer 1

0

Checked in BIOS, no USB legacy support line found with current BIOS.

All USB related lines were enabled, and same behaviour described above with Debian 12 fresh install.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .