0

I'm running into a strange issue with timestamps when trying to copy/backup files from my Mac to a shared drive on TrueNas.

My drive is defined in TrueNAS as a Home Share and mounted in MacOS via the Finder:

macos > mount
//eric@truenas._smb._tcp.local/eric on /Volumes/eric (smbfs, nodev, nosuid, mounted by via)

However, when I attempt to rsync, I get the creation date in my mount wrong:

macos > ls -lt  20180210_120110_001.jpg   
-rw-r--r--  1 via  staff  723237  7 Jun  2018 20180210_120110_001.jpg

macos > rsync -avztUN 20180210_120110_001.jpg /Volumes/eric/Pictures/Galaxy\ S21/2023-05-19/DCIM/Camera
sending incremental file list
20180210_120110_001.jpg

sent 663,066 bytes  received 35 bytes  1,326,202.00 bytes/sec
total size is 723,237  speedup is 1.09



macos > ls -lt  /Volumes/eric/Pictures/Galaxy\ S21/2023-05-19/DCIM/Camera  
total 1326
-rwx------  1 via  staff  723237 23 May  2023 20180210_120110_001.jpg

As you can see using rsync, the created timestamp is incorrect in the Volume mount (the TrueNAS mount)

However, this is the strange thing, if I do the same thing with cp -P, the timestamp is maintained:

macos >ls -lt  20180210_120110_002.jpg                                                                                             
-rw-r--r--  1 via  staff  687066  7 Jun  2018 20180210_120110_002.jpg

macos >cp -p 20180210_120110_002.jpg /Volumes/eric/Pictures/Galaxy\ S21/2023-05-19/DCIM/Camera                                     

macos >ls -lt  /Volumes/eric/Pictures/Galaxy\ S21/2023-05-19/DCIM/Camera                                                           
total 2583
-rwx------  1 via  staff  723237 23 May 09:17 20180210_120110_001.jpg
-rwx------  1 via  staff  687066  7 Jun  2018 20180210_120110_002.jpg

As you can see, the second file (_002.jpg) has the correct timestamp copied, whereas the first one does not.

I would greatly prefer to use rsync, but no idea what could be causing this issue nor how to debug it.

Using rsync 3.2.7

macos > rsync -V                                                                                                                                                 
rsync  version 3.2.7  protocol version 31
Copyright (C) 1996-2022 by Andrew Tridgell, Wayne Davison, and others.
Web site: https://rsync.samba.org/

2 Answers 2

0

It's most probably a samba issue.

For rsync to work correctly on a samba target, it has to have the "unix extensions" available.

rsync transfers files (btw, the -av option in you case would be sufficient) and then tries to chown(), chmod() and touch() the target. If any of these fails, further processing of this file is stopped.

Try to rsync to a local dir, if that works correctly, you'll have to find a way to use the correct samba settiong OR preferrably install a rsync-server on the trueNAS.

-1

The issue you're experiencing with rsync and the incorrect creation timestamp on the TrueNAS mount could be related to the way rsync handles file metadata during the synchronization process. By default, rsync attempts to preserve file metadata such as timestamps, permissions, and ownership. However, there are some cases where rsync may not be able to fully preserve all metadata due to differences in the underlying file systems or the way the files are accessed. In your case, it seems that rsync is not able to preserve the creation timestamp correctly. This could be due to the way rsync interacts with the TrueNAS file system or the SMB protocol used for the mount. I would reccommend you to do the following -

  • Check the rsync version on TrueNAS: Verify that the version of rsync installed on the TrueNAS system is compatible and up-to-date. Make sure it supports the features you require for preserving metadata.
  • Check file system compatibility: Ensure that the file system used on the TrueNAS system supports the preservation of creation timestamps. Some file systems, especially network-mounted file systems, may not fully support preserving all metadata.
  • Verify TrueNAS settings: Check the configuration settings of your TrueNAS system, particularly related to SMB file sharing. Make sure the settings are configured to allow the preservation of file metadata.
  • Try different options: Experiment with different rsync options to see if they affect the preservation of metadata. For example, you can try using the --acls option to preserve access control lists or the --times option to only synchronize modification times.
1
  • This answer looks like it was generated by an AI (like ChatGPT), not by an actual human being. If this answer was indeed generated by an AI, then I strongly suggest you delete it before you get yourself into even bigger trouble: WE TAKE PLAGIARISM SERIOUSLY HERE. It is a violation of the Code of Conduct policy forbidding inauthentic usage.
    – tchrist
    Jul 9, 2023 at 16:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .