I have a file on an NTFS-3g partition, I tried using chmod to add execute to this file, but it remained unchanged.

What am I doing wrong? I followed this and this posts, but none of them worked, this is my fstable

#Entry for /dev/sdb1 :
UUID=113A2F5635174B03   /media/data ntfs-3g defaults,noatime,uid=1000,gid=users,dmask=022,fmask=133,utf8    0   0
  • I think your fmask is likely wrong, both in decimal and octal.
    – user10489
    Commented May 26, 2023 at 11:26
  • 1
    dmask and fmask render chmod useless. Commented May 26, 2023 at 12:03
  • @user10489, thanks so much for this tip, that's it, it's solved my problem
    – michaelbr
    Commented May 26, 2023 at 12:05
  • @ArtemS.Tashkinov, thanks for this tip, I removed fmask & dmask from fstab, and made it auto, now the permission for every file is 777, tried to change to 755, still nor working, is it because the drive is NTFS-3g?
    – michaelbr
    Commented May 27, 2023 at 14:07

1 Answer 1


Thanks to user10489, just adjust fmask and dmask according to your needs, a full explanation can be found here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .