1. I set up a server with the apt-cacher-ng package.
  2. I configured a PC to use this cache. I created /etc/apt/apt.conf.d/02proxy, with this line:
Acquire::http::proxy "http://my-server:3142";
  1. I installed Google Chrome. I.e. downloaded and installed google-chrome-stable_current_amd64.deb.

Q: Later, I noticed a problem if I check for software updates. What happened?

On Ubuntu Desktop 22.04, Software Updater just says "Failed to download repository information. Check your internet connection".

Or on Debian 11 (GNOME), Software shows a popup error:

Unable to download updates:
E: https://dl.google.com/linux/chrome/deb stable InRelease is not (yet) available (Invalid response from proxy: HTTP/1.0 CONNECT denied (ask the admin to enabled HTTPS tunnels) [IP: my-server-IP 3142]

Running apt update shows the full error, on both Ubuntu and Debian.

Finally, if you use Ubuntu 22.04, but switched to using the GNOME Software app (e.g. to avoid snaps), there is no error message at all! It appears that security updates for the Chrome web browser will be skipped, without any warning. Maybe because it's an older version of GNOME Software.

Tested package versions

  • Software Updater on Ubuntu Desktop 22.04 - update-manager 1:22.04.10
  • Software on Debian 11 (GNOME) - gnome-software 3.38.1-1
  • Software on Ubuntu Desktop 22.04 - gnome-software 3.38.1-1
  • apt-cacher-ng 3.6.4-1

1 Answer 1


Google Chrome updates use an encrypted connection (https://). This connection cannot be intercepted and cached.

Firstly, I suggest allowing https:// package repositories to bypass the cache. This avoids the risk that you miss security updates, for any length of time. Edit the apt configuration file you used, and add a second line like this:

Acquire::HTTP::proxy "http://my-server:3142";
Acquire::HTTPS::proxy "DIRECT";

Alternative options are explained in the manual, section 8.3 Access to SSL/TLS remotes (HTTPS).

If you want to cache Google Chrome packages

For Google Chrome, you should first rename /etc/apt/sources.list.d/google-chrome.list to local-google-chrome.list. If you edited this file without moving it, Google say your changes could be automatically overwritten by their cron job or package scripts.

Now you can edit the file. Replace this line:

deb [arch=amd64] https://dl.google.com/linux/chrome/deb/ stable main

with this:

deb [arch=amd64] http://HTTPS///dl.google.com/linux/chrome/deb/ stable main

Remember that if you disable the proxy, you will need to revert this change.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .