1

When I first installed debian I used wpa_supplicant and dhclient to connect to my wifi which so far has worked great, but now I installed network-manager (nmcli) which right away when it finished installing, it disconnected me from my wifi and I cant seem to reconnect, I checked my wifi adapters with nmcli dev status and I get:

DEVICE  TYPE      STATUS       CONNECTION
wlp1s0  wifi      unavailable  --  
lo      loopback  unmanaged    --

I tried to connect to a wifi network with nmcli device wifi connect <ssid> password <password> which returns:

Error: No network with SSID '<ssid>' found.

So just to double check if I had the name wrong I tried nmcli dev wifi list to scan for wifi networks, but this returns and empty table.

I think my wifi drivers are broken so please help, my laptop doesn't have an ethernet port so there is no way for me a download any packages with firmware.

1
  • I personally prefer connman for setting up network in gui. Commented May 15, 2023 at 21:30

2 Answers 2

1

In tests, once I disabled the Wireless interface(s):

nmcli radio wifi off

then I got all of OP's symptoms when trying a known SSID (immediately, without scanning):

$ nmcli device wifi connect <ssid> password <password>
Error: No network with SSID '<ssid>' found.
$ nmcli dev status |grep ' wifi '
wlan0           wifi       unavailable             --         
$ nmcli dev wifi
IN-USE  BSSID  SSID  MODE  CHAN  RATE  SIGNAL  BARS  SECURITY 
$

Just enable it back (this includes doing the equivalent of rfkill unblock ... but also enables back NetworkManager handling, so nmcli should be used, not rfkill):

nmcli radio wifi on

to now get instead:

$ nmcli dev status |grep ' wifi '
wlan0           wifi       disconnected            --         

Now scan results should be available again with nmcli dev wifi list and the connection attempt should work again with nmcli device wifi connect <ssid> password <password>.

0

I fixed it, after installing network-manager, it adds a couple of services that mess with everything.

I disabled them with

sudo systemctl stop NetworkManager

and

sudo systemctl disable NetworkManager-wait-online NetworkManager-dispatcher NetworkManager

If you have the same issue, I hope this helps.

Edit:

I just quickly wanted to add my source: https://linuxbabe.com/debian/connect-to-wi-fi-from-terminal-on-debian-wpa-supplicant

This is the exact same thing I used before I installed network-manager which ruined everything

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .