I just set up a new dedicated server using AlmaLinux 8 and WHM/cpanel.

My other dedicated servers all use Centos 7 and WHM/cpanel.

In SSH as root, on Centos servers, I have always used sudo find / -name filename to find files on the servers

On AlmaLinux 8 in SSH as root sudo find / -name filename gives me the following errors (the process number changes for different sudo find / -name inquiries )

find: ‘/proc/929745/task/929745/net’: Invalid argument
find: ‘/proc/929745/net’: Invalid argument

For some sudo find / -name filename inquiries on AlmaLinux 8 in SSH as root the sudo find / -name filename command actually finds the files in addition to the invalid argument

I would just ignore the invalid argument on AlmaLinux 8, but, sometimes the sudo find / -name filename command doesn't find the file even though the file is definitely on the server

sudo find . -name filename does not find any files on either Centos 7 or AlmaLinux 8, even though the file is definitely on the servers.

Any advice would be greatly appreciated

Thanks Audrey


2 Answers 2


There are a number of questions here. Good practice is to ask only one question at a time.

errors in output on sudo find / -name filename

The /proc filesystem shows you a representation of the running processes on the system. As these processes finish, the directories under /proc are removed. find reads a directory, then for each entry it checks to see if the entry is a directory. If so, it processes it. After it has processed such a sub-directory it continues. If it is looking at say /proc/17 it may find entries fd and fdinfo which are directories. It will then process /proc/17/fd. Suppose process 17 exits. After processing /proc/17/fd it goes to process /proc/17/fdinfo, but /proc/17 and everything under it has gone, so find issues an error message saying it can't find /proc/17/fdinfo.

sometimes sudo find / -name filename doesn't find the file

There is not enough information to help you with this.

sudo find . -name filename does not find any files

Here you are starting with the current directory, so there isn't a file called filename under the current directory.

Find might be the wrong tool.

Depending on what you are wanting to do, it might be that a command like locate might be a better fit.


You may have two problems. The first is that you are scanning /proc you should exclude it. I did the same on my rig. And found this error-message on one process. The process was a zombie. Check the process's status. cat /proc/«pid»/status. The same error could happen if a process exits while being processed.

I won't answer the other bit. An only one question per question.

  • In the command sudo find / -name filename filename is just an example of a filename. WHen I run the command - I use the actual file name. sudo find / -name filename should be consistent with ir't response. I will see what I can figure out
    – Audrey
    May 14 at 17:31
  • I don't grok your comment: most of what you said I already grok (except the word ir't: I have no idea what this word is). I don't see how the comment relates to the answer. The answer still stands. May 17 at 9:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .