1

Using Firefox to open an html file (in fact any file) on a mounted NFS volume gives an "Access to the file was denied" error. Also, similar problem occurs when trying to upload files from a locally connected NFS share to a remote web site, the access hangs. In order to bypass this issue, I must copy the file from the NFS to my local drive and upload it from my local drive. I assume these are aspects of the same issue. It works with Chrome.

  • System details: Linux Mint 20.3 Una base: Ubuntu 20.04 focal
  • About Firefox: Mozilla Firefox for Linux Mint, mint-001 - 1.0

Mount point permissions look fine:

chris@Home:~$ ls -la /shared/
total 124
drwxrwxrwx  24 chris chris  4096 Feb 28 13:06  .
drwxr-xr-x  21 root  root   4096 Aug  6  2022  ..
...

I tried Firefox troubleshooting mode but this was no better. No other programs have a problem reading or writing to this volume, so I assume it's Firefox specific.

I read about problems with the snap package but I don't think this applies here.

I tried setting security.fileuri.strict_origin_policy to false as suggested elsewhere, to no effect.

Any ideas much appreciated!

1
  • I'm still having this issue (I think I was the OP). Any ideas out there?
    – ceperman
    Nov 21, 2023 at 8:32

1 Answer 1

0

I eventually discovered the culprit was AppArmor. I tested this by disabling it completely, but eventually decided just to disable the Firefox profile, using instructions here.

sudo ln -s /etc/apparmor.d/usr.bin.firefox /etc/apparmor.d/disable/
sudo apparmor_parser -R /etc/apparmor.d/disable/usr.bin.firefox

You may need to reboot for this to take effect.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .