0

i just install VMware Workstation player 17 and setup a Windows 10 VM with 4 core CPU and 5GB of Memory, But when the VM turned on it only takes 2GB of host memory and Windows 10 Task Manager shows only single core like it was a 32-bit .

I tried Uninstall and Reinstalling VMware Workstation Player and same problem continues.

I have a Ryzen 7 5825U Processor with 16gb RAM and I'm running a Debian Testing based Distro with kernel version 6.1

Screenshot: Windows System Information

enter image description here

7
  • I see RES at 5250MB which is 5GB which is exactly what you've allocated for your VM. May 13, 2023 at 6:12
  • You didn't happen to install a 32 bit guest OS? May 13, 2023 at 7:04
  • @MarcusMüller its a 64bit OS, But its not using the host memory, i tried with Virtualbox, it uses aroung 8GB
    – HRC
    May 13, 2023 at 11:03
  • @ArtemS.Tashkinov You can see the memory allocated for the VM, but its not using the host memeory, Host memory usage stays at 2GB and i don't know whether its the OS or the VMware!
    – HRC
    May 13, 2023 at 11:05
  • @HRC that's the thing. All you describe points to this VM actually having the 5 GB RAM, but your guest OS only using 2 of them. That sounds like a guest problem, not a host problem. Hence my asking. Can you give us a screenshot of "System Information"; should look something like this I believe. Seen a hint of what is wrong with a customer's PC performance more than once with that, and I'm not even a windows user… May 13, 2023 at 11:18

1 Answer 1

0

You're working under a misconception:

Just because your process reserved 5GB doesn't mean it has to use them. And vice versa, only because your process did not yet use more than 2GB of RAM doesn't mean it has not reserved more.

On basically every modern OS for application processors (so, x86_64, ARMv8…), this is the normal way of dealing with process memory, including the virtualization process.

Your VMWare player correctly reserves 5 GB of memory. But it only access the pages that the executed Windows (and its processes) access – and if they did not yet access all 5GB of RAM, that means the memory "used" is less than the memory "reserved".

So, no problem here; all going according to plan! Which you can clearly see in the Windows screenshot: Windows sees all 5 GB which were reserved. As soon as you actually run memory-intense workloads in that windows, you'll see the memory actually used by the virtualizer grow as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .