I've upgraded to Fedora 38 from 37 and noticed that when my computer is inactive for exactly 30 seconds, the monitors go into power saving mode (presumably because the graphics card (Nvidia RTX 2060, 530.30.02 driver) doesn't provide a signal any more). I checked the usual energy saving dials in Gnome (X11), but couldn't find anything obvious (in fact, I turned off everything that would send the monitors to a sleep).

Where else could I look to avoid the monitors from turning off?


I narrowed down the problem. The issue only occurs after the computer woke up from hibernate. When it actually turns off after 30s of inactivity, there is no log entry.

I also noticed that one of the screens doesn't completely switch off when in hibernate which tells me that hibernate doesn't really work. I also noticed plenty of log entries during the supposed hibernation which means the system was actually running. This issue also doesn't present itself when the system is booted up without prior hibernation.

There is a log entry which may be related, but that occurs during the hibernation (again, which isn't actually happening as per above):

gnome-shell[3556]: segfault at 1 ip 00007fb85595c9ac sp 00007ffc43e28d10 error 4 in libnvidia-glcore.so.530.30.02[7fb854800000+28e5000] likely on CPU 1 (core 1, socket 0)
  • 1
    unix.stackexchange.com/a/110478/191360 What does the log say? May 10, 2023 at 1:58
  • 1
    I'm not the OP, but I think I have valuable data to add, @ChanganAuto. For me, the screen goes blank after 30s of user inactivity. Upon activity, the screen comes back with no sign that system actually suspended. And three copies of the following message get printed to the log: "nvidia-modeset: WARNING: GPU:0: Chimei innolux corp. (DP-3): G-SYNC Compatible: EDID min refresh rate invalid, disabling G-SYNC Compatible." I'm using the proprietary drivers 530.41.03 on a Quadro T2000 with GNOME 44.1 and X11. May 15, 2023 at 4:14
  • 1
    Continuing from my response to @ChanganAuto: I paid closer attention and learned that actually there are two copies of that error message appearing. Experimentation strongly suggests that one is printed when the screen goes blank and the other is printed when the user wakes things back up. So I think the message is only symptomatic, not reflective of the root cause. But there are no other log messages that seem related. May 15, 2023 at 4:28
  • I found no log entry at the time of the screens turning off, but I can confirm that it's exactly 30s as @MadEmperorYuri reports. I also think that it has to do with hibernation as this doesn't occur after a normal reboot (see my updated question).
    – orange
    May 18, 2023 at 0:17
  • I am also getting this at 30 seconds, except I never hibernate. Instead, I use "sleep". I haven't tested yet if this only happens after sleep though. May 19, 2023 at 17:53

1 Answer 1

$ xset s off
$ xset -dpms

solved the issue for me.


  • 1
    Seems to have worked for me but when I've rebooted it stopped working again. May 29, 2023 at 10:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .