0

I have a host running Fedora 36, guest is Win11
I am attempting to share a directory on the host box with a windows 11 guest.

Through research I found that samba is the generally recommended way to accomplish this share.

I have tried creating a virtual network, and connecting to that network In the vm settings
enter image description here


I also tried setting up bridge networking directly to the virb2 host interface.

In both cases I can ping the host from the guest and host to guest. And, I have internet access on the guest.

When I attempt to setup a network drive on the guest, I get "Windows cannot access [server ip][samba shared directory]" enter image description here


Any suggestions? Is there something else I need to do within Windows (I know very little about Windows)?
TIA

Additional Info
tcpdump -i virbr2 -n \(tcp port 139\) returns
12:25:53.866275 IP 192.168.100.189.49908 > 192.168.100.1.netbios-ssn: Flags [S], seq 3481992815, win 64240, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0

iptables -nvL INPUT returns:
Chain INPUT (policy ACCEPT 0 packets, 0 bytes) │ pkts bytes target prot opt in out source destination │ 15895 6287K LIBVIRT_INP all -- * * 0.0.0.0/0 0.0.0.0/0

Firewall Commands I ran to fix the issue

firewall-cmd --zone=libvirt --permanent --add-service=samba
firewall-cmd --reload
5
  • 2
    That sounds a lot like a firewall problem (allowing pings but not access to Samba). You can run tcpdump -i vibr2 -n \(tcp port 139\) or \( tcp port 445 \) on the host in order to check that the Samba connections are received but not answered. What is the output of iptables -nvL INPUT / nft list ruleset? May 7, 2023 at 21:01
  • 1
    Could also be poorly configured samba - without seeing samba config there's no way to be sure May 8, 2023 at 2:49
  • You are throwing the word 'guest' about a lot, now this could just be what you call it, rather than 'server' and 'client', but if you are trying to connect from Windows 11 as a 'Guest' (no username & password), check if guest access is turned on, it is probably off by default. May 8, 2023 at 8:04
  • @HaukeLaging I added the tcpdump output. May 10, 2023 at 16:31
  • @RowlandPenny I am using the KVM terminology for clarity, indicating that this is a virtual machine trying to reach the host via SAMBA May 10, 2023 at 16:35

1 Answer 1

1

The host firewall kills the connection. So you have to explicitly allow the connection (either in the libvirt configuration or in the regular firewall configuration).

1
  • This answer sent me in the right direction. I added the commands I had to run to the question, in order to possibly help others May 12, 2023 at 13:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .