1

I have some RAM that I know for sure is faulty: Memtest86+ reports this as such.

Unfortunately this means that, when I'm forced to restart the machine for an unrelated reason, Linux sometimes incorrectly reports a filesystem issue because of the faulty RAM. Then I'm put into a busybox prompt that forces me to run fsck which I don't want to do because it will read my disk incorrectly and break it further. However, I have no other options. It prevents me from exiting, and restarting the machine just puts me back into the same prompt. The screen I get is:

BusyBox v1.30.1 (Ubuntu 1:1.30,1-7ubuntu3) built-in shell (ash) 
Enter 'help' for a list of built-in commands. 

(initramfs) exit 
/dev/sda3 contains a file system with errors, check forced.
Inodes that were part of a corrupted orphan linked list found. 

/dev/sda3: UNEXPECTED INCONSISTENCY; RUN fsck MRNURLLY. 
        (i.e., without -a or -p options) 
fsck exited with status code 4 
The root filesystem on /dev/sda3 requires a manual fsck 

BusyBox v1.30.1 (Ubuntu 1:1.30.1-7ubuntu3) built-in shell (ash)
Enter 'help' for a list of built-in commands. 

How can I bypass this as a one-off?

2
  • 1
    Stop using the PC, replace the RAM. Commented May 7, 2023 at 11:18
  • 2
    Note, grub2 has 2 commands to reserve memory from use by itself and the kernel, badram and cutmem.
    – meuh
    Commented May 7, 2023 at 13:40

0

You must log in to answer this question.

Browse other questions tagged .