0

I've been following this example to restore capacity to my microSD --> SD card corrupt and stuck at 32MB, any way to fix it?

Everything seems to work until I get to

mkfs /dev/sdx1

It tells me there no such file or directory. If I go to my /dev directory it never created sdx1. I've tried several methods but nothing worked. Any suggestions?

  • 3
    x is a placeholder. You need to use the actual letter Linux assigned. dmesg or lsblk or ls -l /dev/disk/by-id to try to find it. – derobert May 2 '13 at 21:26
  • I know I was using sdg1 which corresponds to mine – ono May 2 '13 at 22:15
  • fdisk -l /dev/sdg, then? – derobert May 2 '13 at 22:47
  • Type lsblk to list all of the block devices on your system. – user26112 May 2 '13 at 23:18
  • if you knew device name i.e /dev/sdg1 then you can use mkfs /dev/sdg1 – Rahul Patil May 3 '13 at 2:18
1

You are trying to access the first partition of this device. Since you say it is corrupted, the partition table is corrupted, too. So your system only recognizes the device /dev/sdx but not partitions sdx1, sdx2, etc. Try fdisk /dev/sdx, cfdisk /dev/sdx or parted /dev/sdx to check the partition table.

  • That may be the scenario but I followed the steps to create a new partition table. This partition table should not be corrupted. Why the new sdg1 is never created is what my question is. – ono May 3 '13 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.