0

I have a new Mint Cinnamon 21.1 installation on my Dell Inspiron dual boot with Windows 7 and a problem with my usb modem Huawei E173u-2. Right after Mint installation modem worked great, it was detected, I was able to create a connection in Network Manager and connect to internet. No problem. I leave it for a few hours and ended up with broken connection. So I tried to connect it again but I can't do it anymore. Something happened and now Network Manager applet won't display my internet provider name and its signal strength and I can't make connection through modem. I'm stuck with "Connection failed. Activation of network connection failed."; "Disconnected". The same modem works great with Mint Cinnamon 21.1 live usb from pendrive. And it worked great with Mint 19.3 for the last two years. The only thing I did before it broken down was changing my user password.

I reinstalled Network Manager, I tried another kernel, still no connection. Changing ports - nothing. Power Managament is off.

Now it's three days later and I'm at the end of my rope. It worked right away and now it doesn't. I can't use internet, modem won't connect, The Mobile Broadband doesn't show up in Network Setting, but I have no problem to create connection in Network Connection, but it won't make the connection. Signal is ok, port usb is ok, modem is ok. Network Manager works with wifi and usb tethering from my smartphone without any problem. Network Manager, Modem Manager and usb-modeswitch are up to date.

What else besides reinstalling Mint I can do to make it work again? Why my modem won't work anymore and how to fix it? How can I found what is the cause of this problem?

inxi -Fxxrzc0

System:
  Kernel: 5.15.0-69-generic x86_64 bits: 64 compiler: gcc v: 11.3.0
    Desktop: Cinnamon 5.6.8 tk: GTK 3.24.33 wm: muffin dm: LightDM
    Distro: Linux Mint 21.1 Vera base: Ubuntu 22.04 jammy
Machine:
  Type: Portable System: Dell product: Inspiron N5050 v: N/A
    serial: <superuser required> Chassis: type: 8 serial: <superuser required>
  Mobo: Dell model: 01HXXJ v: A05 serial: <superuser required> BIOS: Dell
    v: A05 date: 08/03/2012
CPU:
  Info: dual core model: Intel Core i5-2430M bits: 64 type: MT MCP
    arch: Sandy Bridge rev: 7 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 798 high: 799 min/max: 800/3000 cores: 1: 798 2: 799
    3: 798 4: 798 bogomips: 19156
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Dell driver: i915 v: kernel ports: active: LVDS-1
    empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0116
  Device-2: Realtek Integrated Webcam type: USB driver: uvcvideo
    bus-ID: 1-1.5:5 chip-ID: 0bda:58c0
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: modesetting
    unloaded: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96
  Monitor-1: LVDS-1 model: AU Optronics res: 1366x768 dpi: 101
    diag: 394mm (15.5")
  OpenGL: renderer: Mesa Intel HD Graphics 3000 (SNB GT2)
    v: 3.3 Mesa 22.2.5 direct render: Yes
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20
  Sound Server-1: ALSA v: k5.15.0-69-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: e000
    bus-ID: 05:00.0 chip-ID: 10ec:8136
  IF: enp5s0 state: down mac: <filter>
  Device-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter
    vendor: Dell driver: wl v: kernel pcie: speed: 2.5 GT/s lanes: 1
    bus-ID: 09:00.0 chip-ID: 14e4:4727
  IF: wlp9s0 state: up mac: <filter>
  Device-3: Huawei Broadband stick type: USB
    driver: cdc_ether,option,option1,usb-storage bus-ID: 1-1.1:3
    chip-ID: 12d1:1436
  IF: wwx0250f3000000 state: down mac: <filter>
Bluetooth:
  Device-1: Broadcom BCM2070 Bluetooth 2.1 + EDR type: USB driver: btusb
    v: 0.8 bus-ID: 1-1.4:4 chip-ID: 0a5c:21bc
  Report: hciconfig ID: hci0 rfk-id: 2 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 154.66 GiB (33.2%)
  ID-1: /dev/sda vendor: Western Digital model: WD5000BPVT-75HXZT3
    size: 465.76 GiB speed: 3.0 Gb/s serial: <filter>
Partition:
  ID-1: / size: 40.48 GiB used: 16 GiB (39.5%) fs: ext4 dev: /dev/sda6
Swap:
  ID-1: swap-1 type: partition size: 7.63 GiB used: 45 MiB (0.6%)
    priority: -2 dev: /dev/sda5
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
Repos:
  Packages: 2596 apt: 2592 snap: 4
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list
    1: deb http://dl.google.com/linux/chrome/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
    1: deb [arch=amd64] https://dl.google.com/linux/chrome/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
    1: deb http://packages.linuxmint.com vera main upstream import backport
    2: deb http://archive.ubuntu.com/ubuntu jammy main restricted universe multiverse
    3: deb http://archive.ubuntu.com/ubuntu jammy-updates main restricted universe multiverse
    4: deb http://archive.ubuntu.com/ubuntu jammy-backports main restricted universe multiverse
    5: deb http://security.ubuntu.com/ubuntu/ jammy-security main restricted universe multiverse
Info:
  Processes: 275 Uptime: 3h 18m Memory: 3.74 GiB used: 2.8 GiB (74.8%)
  Init: systemd v: 249 runlevel: 5 Compilers: gcc: 11.3.0 alt: 11/12
  Shell: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.13

lsusb

Bus 002 Device 004: ID 0bda:0138 Realtek Semiconductor Corp. RTS5138 Card Reader Controller
Bus 002 Device 003: ID 093a:2521 Pixart Imaging, Inc. Optical Mouse
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 0bda:58c0 Realtek Semiconductor Corp. Integrated Webcam
Bus 001 Device 004: ID 0a5c:21bc Broadcom Corp. BCM2070 Bluetooth 2.1 + EDR
Bus 001 Device 003: ID 12d1:1436 Huawei Technologies Co., Ltd. Broadband stick
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

mmcli -L

/org/freedesktop/ModemManager1/Modem/0 [huawei] E173

I'm a noob in Linux, so any things you want me to do in order to help me solve this problem need to be communicated in clear and very step by step way like you would talk to a total newbie. Thanks in advance.

2
  • Have you tried it in another computer? Preferably because although you have dual-boot you shouldn't use an obsolete, unsupported and unsafe Windows 7 even for tests like this. The first thing you need to confirm is whether or not the modem still works (and/or your mobile service, of course). Then, after confirming it works elsewhere, you should jump to troubleshooting your Linux. Commented Apr 24, 2023 at 9:29
  • I already tested modem and mobile service. Both work fine.
    – Avina
    Commented Apr 25, 2023 at 19:59

1 Answer 1

0

The problem was caused by modem manager version 1.20.0-1~ubuntu22.04.1. With version 1.18.6-1 modem works great. I found about it after reinstalling my mint and looking carefully at updates in update manager.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .