1

Normally in Openbox I can move windows around by holding Alt and grabbing the window with left mouse button.

But sometimes I accidentally "grab" a window and then it is stuck to my mouse without holding any keyboard key. The window moves with my mouse, and my mouse cursor changes to a "hand" cursors.

I can never find out how I did it, but it happens often enough, usually when I am doing something fast on the keyboard in the lower left corner around Alt and Ctrl and moving mouse simultaneously.

Anyway, how can I disable this?

1 Answer 1

0

Open the openbox config file in a text editor:

vi ~/.config/openbox/rc.xml

Comment out the "Move" action section in the block:

<!--
<mousebind button="Left" action="Drag">
    <action name="Move"/>
</mousebind>
-->

Save, exit and restart the service:

openbox --restart

If you want to disable Alt+Left mouse button drag behaviour as well, you can comment out this section too.

<mousebind button="A-Left" action="Drag">
    <action name="Move"/>
</mousebind>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .