This is driving me absolutely batty. I have two shares:

  comment = applications
  path = /mnt/applications
  browseable = yes
  read only = no
  guest ok = no
  valid users = andrew
  create mask = 0770

  comment = media
  path = /mnt/media
  writeable = yes
  public = yes
  guest ok = yes
  create mask = 0777

I have a VM with the following fstab:

// /mnt/media cifs vers=3.0,rw,noserverino,users,_netdev,credentials=/root/.smbcredentials,x-systemd.automount,noauto 0 0 >
// /mnt/applications cifs vers=3.0,users,credentials=/root/.smbcredentials,_netdev,x-systemd.automount,noauto 0 0

(I know, the mounts are ugly, but it took a lot of trial and error to get the setup functional and I didn't want to break anything by cleaning it)

This was working fine, until I needed to move everything to a new SSD. After restoring everything from backups, Media mount won't automount. I get the following during boot:

[FAILED] Failed to mount /mnt/media
CIFS: VFS: Error connecting to socket. Aborting operation.
CIFS: VFS: cifs_mount failed w/return code = -101

The Applications mount has zero issues auto-mounting.

'sudo mount -a' doesn't give any response.

When I manually mount using:

mount // /mnt/media

I am asked for password and once I enter it the share mounts just fine.

Has anybody seen something like this?

  • Might be a timing problem. Is the network really up at this point?
    – stoney
    May 3 at 19:51

1 Answer 1


Usually error 101 is network related, this is one thing. You said that you got advance mounting the volume manually, but in your command there's no options. This can difficult things to you while trying to reproduce the scenario manually. A better approach would be using :

sudo mount -t cifs -o vers=3.0,rw,noserverino,users,_netdev,credentials=/root/.smbcredentials,x-systemd.automount,noauto // /mnt/media

This way you can see what's wrong with your mount request.

Also, after any change in fstab I would recommend you to reload system units by executing :

sudo systemctl daemon reload
  • Thanks for your reply! 101 apparently is a network issue, but I'm perplexed as to why the other share mounts without issue, having to also require network access. sudo mount -t cifs -o vers=3.0,rw,noserverino,users,_netdev,credentials=/root/.smbcredentials,x-systemd.automount,noauto // /mnt/media actually mounts without issue Apr 20 at 17:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .