1

I was running Fedora 34 until now. Fedora 38 came out and I moved to that. I'm using MATE with Gnome Terminal. The font is set to Monospace 13 in both systems. Yet there's a difference in the font. What I don't like in Fedora 38. How could I have the same font like I had in Fedora 34? The change can be seen especially on "r"

enter image description here

1 Answer 1

4

"Monospace" is not a real font; it's merely an alias to some or other font, which traditionally used to be DejaVu Sans Mono on Linux for about a decade – with the distinct flattened @ shape as in your "original" screenshot.

(DejaVu fonts weren't really great fonts though, merely decent, but for a long time there weren't any better FOSS fonts available, especially for a distro such as Fedora that was strongly concerned with licensing. However, now that more free fonts exist, it is not surprising that Fedora has changed the default.)

If you run fc-match Monospace you will see the current mapping.

How could I have the same font like I had in Fedora 34?

First, install the fonts. Fedora no longer includes DejaVu by default, so install dejavu-sans-fonts via DNF (or download them from GitHub into your ~/.local/share/fonts/).

Once installed, just change the terminal font through GNOME Terminal's "Profiles > Default".


Changing font aliases system-wide

Within GNOME, the org.gnome.desktop.interface monospace-font-name GSetting might be the one that controls the alias system-wide (although of course you can just change it for the terminal alone; it's fine to use one monospace font for terminals and another for normal text).

  • GNOME Tweaks > Fonts > Monospace Text
  • regedit: dconf-editor > /org/gnome/desktop/interface/monospace-font-name
  • gsettings set org.gnome.desktop.interface monospace-font-name "Something 11"

Outside of GNOME, such aliases are defined via Fontconfig (e.g. /etc/fonts/conf.d). For example, create a ~/.config/fontconfig/fonts.conf that contains:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "urn:fontconfig:fonts.dtd">
<fontconfig>

    <alias>
        <family>Monospace</family>
        <prefer>
            <family>DejaVu Something Or Other</family>
        </prefer>
    </alias>

</fontconfig>

as documented in man fonts.conf.

9
  • This is the fc-match output for 34: DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book" and for 38: NotoSansMono[wght].ttf: "Noto Sans Mono" "Regular" Apr 20, 2023 at 7:06
  • Oh, so they did switch to Noto fonts for everything. I thought that was only for (sans-)serif. Point remains, change your terminal to use DejaVu Sans Mono if you want the old font. Apr 20, 2023 at 7:10
  • could you please drop me the exact command to be executed? I don't want to ruin something, Apr 20, 2023 at 7:14
  • If you only want it for the terminal, just do it through the terminal's graphical settings. If you want it system-wide, install GNOME Tweaks and change it from there. (Or failing that, install dconf-editor which is the "GNOME regedit".) Apr 20, 2023 at 7:15
  • yes, I want it only for the terminal, but I cannot see such an option in the settings... :( Apr 20, 2023 at 7:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .