0

Having trouble completing sudo apt-get upgrade i get the following error:

dpkg: error processing package apache2-utils (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
Errors were encountered while processing:
 apache2-utils
E: Sub-process /usr/bin/dpkg returned an error code (1)

Im unable to remove it either.

dpkg: error processing package apache2-utils (--remove):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting a removal
dpkg: too many errors, stopping
Errors were encountered while processing:
 apache2-utils
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

ubuntu 22

How can i fix this problem?

edit:

Tried reinstalling it.

sudo apt-get install apache2-utils                                                                                                                                                                                                                  

[sudo] password for kay: Reading package lists... Done Building dependency tree... Done Reading state information... Done apache2-utils is already the newest version (2.4.52-1ubuntu4.4). The following packages were automatically installed and are no longer required: libllvm13 libllvm13:i386 libvulkan1:i386 libxcb-randr0:i386 mesa-vulkan-drivers:i386 Use 'sudo apt autoremove' to remove them. 0 to upgrade, 0 to newly install, 0 to remove and 12 not to upgrade. 1 not fully installed or removed. Need to get 0 B/89.5 kB of archives. After this operation, 0 B of additional disk space will be used. Do you want to continue? [Y/n] Y dpkg: error processing package apache2-utils (--configure): package is in a very bad inconsistent state; you should reinstall it before attempting configuration Errors were encountered while processing: apache2-utils E: Sub-process /usr/bin/dpkg returned an error code (1)

2
  • 1
    … and you did try what the error message explicitly recommends you do, I suppose? Commented Apr 8, 2023 at 9:55
  • yes i tried to reinstall it and i get the same error: dpkg: too many errors, stopping Errors were encountered while processing: apache2-utils Processing was halted because there were too many errors. E: Sub-process /usr/bin/dpkg returned an error code (1)
    – Kay
    Commented Apr 8, 2023 at 14:46

1 Answer 1

1

Re-installing isn’t quite the same as installing; you need to run

sudo apt-get reinstall apache2-utils

Running apt-get install in your case doesn’t help: apt-get sees that the package is already installed and doesn’t install it again. reinstall forces it to be re-installed, replacing missing files etc.

1
  • thank you, i had no idea there was a reinstall command
    – Kay
    Commented Apr 10, 2023 at 11:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .