1

I just installed debian bullseye on a lenovo Thinkpad X1 Carbon Gen 10.

The installation process was pretty straightforward. Except for one part: networking. During the installation, it said the wifi card was not recognized.

Apparently this is a known case. I am just supposed to install the firmware-iwlwifi package and everything is supposed to be fine.

Thanks to an usb driver I uploaded this file ftp.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-iwlwifi_20210315-3_all.deb to the laptop and ran dpkg -i.

apt search iwl
firmware-iwlwifi/now 20210315-3 all [installed,local]
  Binary firmware for Intel Wireless cards

However, lsmod | grep iwl initally doesn't show that the iwlwifi module, suggesting it's not loaded.

After modprobe iwlwifi, lsmod | grep iwl displays:

iwlwifi     299008  0
cfg80211    983040  1 iwlwifi

I interpret the third column being at 0 as "the driver is not being used".

Finally, lspci -nnkv | sed -n '/Network/,/^$/p' doesn't show the line Kernel driver in use: iwlwifi Kernel modules: iwlwifi like on this page https://wiki.debian.org/InstallingDebianOn/Thinkpad/X1%20Carbon%20Gen%2810%29/bullseye.

Even after rebooting, making sure the kernel module is loaded at boot time (adding iwlwifi in /etc/modules), I don't have a wifi network interface (ip a show).

At this point I'm lost. I feel something's wrong but can't identify what. The installation guide on the debian wiki I linked above proposes some commands to run but none of them seem to be about wifi.

Isn't the iwlwifi module supposed to load automatically after installing the firmware-iwlwifi package?

What am I missing to make the Intel network device use that module?

Note: I don't have access to internet via ethernet. I tried plugging an USB-C to ethernet adapter and an RJ45 cable but for some reason the ethernet interface doesn't go up either.

1
  • 2
    There's one difference between the linked page and your system: versions. You're running vanilla Debian, which comes with kernel 5.10 and your iwlwifi driver is dated March 2021. The writer updated theirs to 5.18 and their driver is from August 2022. X1 Gen10 was released January 2022. I'd suggest updating and seeing whether that fixes the issue. Apr 8, 2023 at 6:09

1 Answer 1

0

I solved my issue by sharing an internet connection with my phone via USB.

I installed the latest kernel and it seemed to have fixed the issue.

The best hypothesis I have is, as @Peregrino69 mentioned, that my driver version was not aligned with my kernel version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .