1

Each new release of openZFS has a range of supported linux kernel versions (for example openZFS v2.1.9 supports kernels versions between 3.10 and 6.1)

But when I run zfs version I get:

root@pve:~# zfs version
zfs-2.1.9-pve1
zfs-kmod-2.1.6-pve1

PVE it's because I'm running proxmox virtual environment distribution, but at the end of the day it's debian (11) with some virtualization glitter on top.

So my question is, what linux kernel versions can I install? Because zfs version returns two different versions that have different linux support. For example, zfs 2.1.6 only supports up to linux 5.19. So, what's the important version, zfs or zfs-kmod?

EDIT: Also, should those two versions, zfs and zfs-kmod, be the same?

3
  • 3
    shouldn't these two versions match, anyway? I'm not an ZFS expert, but -kmod is for "kernel module", so that's probably the relevant version. Apr 3, 2023 at 7:36
  • That's another good question... I'm not a ZFS expert neither, so I can't answer it myself, but it's a good point.
    – Héctor
    Apr 3, 2023 at 7:41
  • I can't say anything specific, but it feels as if it would be the kernel module package version number that determines what Linux kernels it can interact with.
    – Kusalananda
    Apr 3, 2023 at 9:50

1 Answer 1

0

I have found out.

As zfs-kmod it's a kernel module, it gets embedded into the kernel package. So it's the maintainer of the kernel package who should place a compatible version of the zfs-kmod in their kernel package (if they want to support zfs).

To check the zfs-kmod version of installed kernels without having to boot from them I have used strings /usr/lib/modules/*/zfs/zfs.ko | grep -e ^version= -e vermagic= | grep -v % that returns the kernel versions and their associated zfs kernel module version. In my case:

version=2.1.9-pve1
vermagic=5.15.102-1-pve SMP mod_unload modversions
version=2.1.6-pve1
vermagic=5.15.74-1-pve SMP mod_unload modversions
version=2.1.9-pve1
vermagic=5.15.85-1-pve SMP mod_unload modversions
version=2.1.6-pve1
vermagic=5.19.17-1-pve SMP preempt mod_unload modversions
version=2.1.9-pve1
vermagic=6.1.15-1-pve SMP preempt mod_unload modversions

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .