4

I have an extra systemd-boot entry for OpenBSD.

 $ cat /boot/loader/entries/bsd.conf
title OpenBSD
efi /extra/bootx64.efi

It works and I manage to get into boot shell,

The problem is that by default it tries to boot from hd0, I need it to boot from hd1, which I have to specify manually with

> set device hd1

I tried the following, but it didn't work

 $ cat /boot/loader/entries/bsd.conf
title OpenBSD
efi /extra/bootx64.efi
options set device hd1a # it does not work

Is there a way to pass hd1 as a parameter to bootx64.efi, without typing it manually?

1

1 Answer 1

0

Try putting set device hd1a in your /etc/boot.conf on your OpenBSD a partition.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .