0

I made my Arcolinux (5.12.14-arch1-1 x86_64) unusable by trying to install openssh. Googled a few hours and tried something, but without success.

I did the following:

$sudo pacman -S openvpn

Then vpn sayed that it requires oppenssl, so I installed it

$sudo pacman -S openssl

Then I tried to start openvpn and got an error "missing libcrypto.so.1.1"

Unfortunately many applications (including sudo and pacman!) seem to depend on this library so I can not start them anymore.

After some googling I downloaded libcrypto from here https://archlinux.org/packages/core/x86_64/openssl-1.1/ And copied the libcrypto.so.1.1 file to /usr/lib/ (using sh, because sudo wont work)

Then I tried to start pacman und sudo again and got another error:

sudo: /usr/lib/libc.so.6: version `GLIBC_2.34' not found (required by /usr/lib/libcrypto.so.1.1)

Now, probably I could try to coppy this file as well and so on, but I think this is not the right way to solve the problem cleanly.

How can I revert to the state before instaling openssl (above)

What did I wrong while installing openssh? I thought / relied on that pacman considers the dependencies and does not remove a lib automatically if there is another app or lib that depends on it?

Many thanks for hints or guidance!

1 Answer 1

1

Based on your kernel version (5.12.14-arch1-1 x86_64) you apparently haven't updated your Arch installation in about 15 months.

Keeping up with a rolling-release distribution like Arch tends to require frequent updating. The distribution maintainers cannot guarantee that you will be able to install the newest packages to any old installation: the web of dependencies that needs to be managed becomes exponentially more complex as the time range between your currently installed packages and the up-to-date state of the distribution grows.

Unless all the packages have their dependency information absolutely perfect all the time, as the time between updates grows, so does also the risk of encountering a dependency that is not automatically detectable. And for you, that risk seems to have been realized.

You should have installed all updates to your installed packages at least once a month, maybe even once a week.

Instead, you installed the absolutely latest packages of openvpn and openssl into your one-and-half-years old system. Unfortunately, it looks like the new openssl is built against a newer version of glibc than your system currently has. In order to solve this problem, you might have needed a version of openssl that is somewhere in between your system's original version and the current up-to-date version... but it is possible that the version you would need has already expired from Arch's repositories, since your system is in such an old state. If so, then "there is no way to get there from here": the rolling release has rolled away from you and you can't catch it any more.

The easiest way forward would be to restore from a backup, and then attempt a full upgrade to the up-to-date state before trying to install any software that is not already present. But even that might not be successful, since your system seems to be in such an old state.

It might be possible to recover from your current situation with a "manual intervention" (as the Arch Wiki calls it), however it is likely that reinstalling from scratch and restoring your data from backup might be easier and faster.

If you don't have a backup? Then I would suggest booting from some external media, mounting the filesystems of this installation, backing up all your data and configuration files, and then reinstalling.

1
  • Thanks telco for your explanations. In expectation of further trouble when rebooting I saved the data and some settings. And actually I got a Kernel panic while rebooting caused by the missing GLIBC_2.34. So for me (no linux professional) probably is the cleanest way to reinstall Arco Linux. Lesson lerned: keep it up to date:)
    – leol
    Mar 30, 2023 at 21:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .