2

When I do something (whatever) that results in a shut down, restart or sleep (for example usual shut down or restart, closing the lid, etc.), fedora 18 (x86_64 , GNOME desktop) comes up with an error (below). Can you help me with this?

Not all file systems unmounted, 1 left
cannot finalize remaining file systems and devices, giving up

screenshot

    http://i.stack.imgur.com/iYvEO.jpg

Should I unmount added devices (other drives) manually before shutdown?

EDIT #1

I tried, as user:IBr suggested, to reboot from tty and it worked. So the problem occurs only in GNOME.

  • 1
    If the same is returned when you go to tty ctrl + alt + f2 and do systemctl shutdown ? – IBr Apr 29 '13 at 19:32
  • What devices are you adding? Maybe posting the output of df will help people understand the problem better. – drs Apr 29 '13 at 19:34
  • You can also try unmounting your added devices manually and seeing if one of them hangs. – drs Apr 29 '13 at 19:43
  • @IBr No. It reboots properly there. – Mo_ Apr 29 '13 at 19:43
  • 1
    I updated the kernel to 3.8.9 and now the problem has gone!(before update it was 3.6.10_4 ) – Mo_ Apr 30 '13 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.