I'm trying to run sudo make dt_binding_check Documentation/devicetree/bindings/xilinx-xadc.yaml and I get an error

Error: Documentation/devicetree/bindings/iio/adc/xilinx-xadc.example.dts:22.25-41 syntax error
FATAL ERROR: Unable to parse input tree

Looking through the web, I found answers suggesting that I would need to run the .dts file through the C preprocessor first and then run dtc on it. I did this, but I keep getting the following error: FATAL ERROR: Couldn't open "Documentation/devicetree/bindings/xilinx-xadc.examplepreprocessed.dts": Permission denied. I don't get how permission can be denied since I ran it using sudo. I figured then maybe somehow the computer is UNABLE to open it,so I set the default application to open .dts files as Vim and then Text Editor,both don't work and I keep getting the same error. Any help from you guys will be appreciated.

New contributor
Venkaat Balaje is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.


Your Answer

Venkaat Balaje is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.