I need to install a Linux distribution on my ARM64 laptop, but it just won't work. I have already tried several stuff and none of them work.

Can anybody point me out anything I could do?

I have already tried:

Generic Arch Linux AARCH64

Fedora ARM

OpenSuse AARCH64




Snapdragon 8cx Mobile Platforms

New contributor
MustSee is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 6
    You are unlikely to get any help by saying it just doesn’t work. When you have tried to install what happens? Do you have issues installing? Does it install and not boot.
    – PonJar
    Mar 15 at 11:57
  • 5
    Welcome to U&L. Sorry but "it just won't work" doesn't tell anything useful. Instead please describe what exactly happens - "When I do X I expect Y but Z happens instead". What exactly are you trying to install to, and how exactly is important. See the guidelines on writing a question in the Help center. The devil's in the details. Mar 15 at 11:59
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Mar 16 at 11:06


Your Answer

MustSee is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.