I am using Mobaxterm to access cluster that is running on Bash. I have an absurd, but very annoying issue.

  • When I installed Mobaxterm, Tab completion would end the path with a / and if you press it again, it would list all files and subdirectories in that path.
  • I have no idea what happened, but now as soon as I type a directory name, Tab completion ends with a blank space instead by / which is extremely annoying if I wanted to navigate further down the directory tree.

To clarify this issue by an example, let's say I have the following directory structure:


When I type nano src/lib1 and press Tab I am expecting autocomplete src/lib1/. Hitting Tab again would then list file.cpp.

Instead what happens is that I get src/lib1 so I have to delete blank space, type / manually and only then would things work.

I hope you can imagine how frustrating this is when navigating through loads of directories.

Overall, I want bash to add trailing / after each path during autocompletion, any idea how to enable this?

  • that's a problem on your Windows frontend, not on the Unix backend. Mar 14 at 12:39
  • A cluster running on bash? That's quite something.
    – symcbean
    Mar 15 at 14:24


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.