1

I just bought a Raspberry Pi Zero W and instelled 32bit OS. I followed all the instruction and installed CUPS printing server. I go to http://localhost:631 press the Administration button, i add my printer and select Generic Manufacturer and IPP driver. My printer gets added correctly but i cant do any printing at all. Not test page not mobile printing. My printer is Konica Minolta 225i and i cant find PPD drivers anywhere. I also tried RAW drivers and some Konica drivers from other models but not even one worked. I also tried connecting to the printer to CUPS not only via USB but via Network as well. Same result. The raspberry Pi is set up correctly because when i try adding my second printer everything prints fine.

Can ypu please help me? Thanks in advance

2 Answers 2

0

Access the CUPS (Common Unix Printing Sysyem) GUI by pointing your browser to http://localhost:631.

You can detect, add, and manage printers from the Admin tab, and deal with individual printers including picking a driver for your printer) from the Printers tab. You can set the system default printer.

From the command line,

lpstat -t

will show the total state of the printing system.

2
  • Hi and thanks for your response. Unfortunately, I have done the things you mention over 20 times. Each time trying a new GENERIC or RAW printer driver. I have also triesd installing the printer both via USB cable as well as via my network. Its time i have the same problem. The printer gets installed without a problem and is visible as a wireless printer from m pc and phone. when i try to print something i get the message that the command has been sent to the printer successfully but nothing happens.. Any ideas?
    – Kostas
    Commented Mar 10, 2023 at 2:02
  • Unix&Linux is a Question and Answer site, not a conversation site. To help other users, Questions and Answers are rated, and indexed. Comments are not. If you have another question, ask another Question. Please read askubuntu.com/help/how-to-ask and askubuntu.com/help/formatting
    – waltinator
    Commented Apr 28, 2023 at 0:32
0

You can find the ppd file in the Linux drivers downloaded from Konika Minolta website. But you will also probably need other files, like the cupsfilter.

Here is the way to get the ppd file:

The file to download is a zip. It contains rpm files for SUSE or Redhat: Konika Minolta driver download page. On this page, you have to search "225i", then choose "Linux" in the "drivers" section.

The zip driver file contains the following files for 32 bit Linux:

  • Redhat5/konica-minolta-225igdi-cups-1.00-0.i386.rpm
  • SUSE/konica-minolta-225igdi-cups-1.00-0.i386.rpm

You can choose one of these file.

If your archiver software can't open rpm files, you need to install rpm2cpio package. Then run the following command to convert the rpm file to a tgz file:

rpm2archive ./konica-minolta-225igdi-cups-1.00-0.i386.rpm

It will create a file named konica-minolta-225igdi-cups-1.00-0.i386.rpm.tgz, that you can now extract using your archiver software or using the commands gunzip and tar.

The extraction should create a directory named ./usr.

The ppd file will be in the directory ./usr/share/cups/model/KonicaMinolta, and it is named 225igdi.ppd.

You can give the ppd file to the cups server when you add the printer.

But the ppd file references some other files like the cupsfilter, if they are binaries, then they are compiled for i386, so they won't work on the Raspberry.

Edit:

I heard about box86, that is able to run some 32 bits x86 Linux softwares on 32 bits ARM architecture with a Linux OS.

So, maybe it is possible to force the Linux system on the Raspberry to run the cupsfilter using box86. Maybe by editing the ppd file, replacing the cupsfilter reference by the path to a shell script that run the cupsfilter using box86.

For 64 bits ARM, there is also box64, that can run some x86_64 linux softwares.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .