I'm using ubuntu 22.04, with linux kernel 5.19.0

My laptop has a dead hard drive, which is very sad, but I can't do much about it.

What I (hope I) can do however, is finding a way to avoid having to endure a full minute of ata1: COMRESET failed (errno=-16) at each reboot.

From this answer, I found that I could override this behaviour by adding libata.force=1:disable to grub linux boot parameters. When I do it manually at boot time, it works perfectly fine. So I tried to do it by default, by editing this line of /etc/default/grub from: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash", to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash libata.force=1:disable".

When rebooting, the actual command line ends up being: linux [ *some random stuff* ] quiet splash libata.force=1:disable $vt_handoff with $vt_handoff being appended automatically.

This is where my problem begins: it seems that the parameter I added is ignored when placed in penultimate position like this (one full minute of COMRESET failed, etc...). When I move it back in last position, it works as intended. Of course, I don't want to have to do it each time I need to reboot.

So my here's my actual question: is there a way to either:

  • Force my boot parameter in last position
  • Make it so my boot parameter isn't ignored
  • Implement some other (better?) way of doing what I want (I don't know much about the way grub works, I'm just trying some stuff I found)


You must log in to answer this question.

Browse other questions tagged .