enter image description here

Above, you can see the output of the kscreen-doctor -o command on Suse Tumbleweed.

I tried kscreen-doctor -o | cat to no avail.

Short of using a black background as a damage limiting device (still Angry Fruit Salad, but at least I can read the text), what can I do to remove the garish colors from the output?

NB I have used kscreen doctor as an example, but there are other culprits as well. E.g., apt in Debian uses a bright yellow to output info during downloading, and to change the color one of the developers suggested to use A LITERAL ESCAPE CHARACTER in Apt's global configuration file

  • Do you want no colors or better colors? I suspect this might be using your $LS_COLORS variable, have you tried changing that to see if you can get a color palette that is more to your liking? I get a much nicer output on my system and it looks like it's using my LS_COLORS. See Terminator custom colors overriden by KDE for help on changing it.
    – terdon
    Mar 8 at 15:37
  • Hmm no, actually, I think LS_COLORS is irrelevant. The colors seem to be hardcoded in the source code: github.com/KDE/libkscreen/blob/master/src/doctor/doctor.cpp
    – terdon
    Mar 8 at 15:44
  • @terdon "Do you want no colors or better colors?" No colors.\n Restricting the conversation to kscreen-doctor: ① what is wrong with xrandr? ② it seems that the developers used colors as a POOR substitute of a proper formatting (e.g., xrandr ) and ③ why hardcoded the colors? (e.g., IPython console has the %color LightBg magic).
    – gboffi
    Mar 8 at 19:17

1 Answer 1


I use RHEL/CentOS 7 and 8, and in those I...

  • edit /etc/profile.d/colorls.sh
    • bottom of file which has alias ls color=auto for all color instances I change auto to none
    • this will turn off coloring in the terminal window
  • in your home account create a ~/.vimrc file
    • with the line containing syntax none
    • this will turn off coloring when using vim which I also despise

The only coloring I do like is the prompt, or certain parts of the prompt. Especially having the prompt red when root. See here to do prompt color:

red terminal font when root

that is my standard practice, to have the plain black window with only white letters and no fruit salad. In SUSE/SLES I do not know if they use the /etc/profile.d convention; if not I think you just want to change the alias ls from having some color= content.

... assuming your fruit salad output is not directly caused by your use of kscreen-doctor, an app which I am not familiar with. I have written basic C code where I print characters in a certain color when desired, like a green OK using \033[32m (which I believe is an escape sequence?) so if kscreen-doctor does something like that that then I'm not sure how to undo that effect outside of that program.


Not the answer you're looking for? Browse other questions tagged .