I'd like to access the music library from my desktop with my Raspberry Pi, and I'd like to do this via Samba/cifs.

I did the following:

Set the folder Q:\musik as a shared folder on my Windows machine (which has a local IP of, accessible (read, execute and show folder contents) to any user. It appears as musik when I look at the network panel and look at the name of the windows machine.

Open a terminal and type the following:

mkdir mountmusik
sudo mount -t cifs // mountmusik

This results in the contents of musikbeing shown in mountmusik.

However, there are things which don't work as I'd like to: Plain txt files appear to consist of whitespace, with the exception of theer unreadable characters at the start of the file.

I'm not sure if I omitted vital information when I tried to mount, or if I should have granted a broader access on the windows machine.

Edit: It turned out that there were several issues at work. The mp3 files did not play because I was using a non-functional mp3 player program. Now, playing mp3 files works like a charm since I swapped to VLC after installing mpg123. This was my main issue, but I'm keeping up the question because the txt files are still not able to be read properly and jpg files are not able to be opened.

  • when you say local mp3's play fine ... does that mean that if you copied one of the mp3's from the windows share to the pi first it plays OK?
    – tink
    Apr 28, 2013 at 18:37
  • I was able to play local files (which I originally copied via SCP) using omxplayer. I assumed it would be no issue to use a different player, namely audacious. It turned out: This was the issue. Switching to VLC allowed me to play the files from the mounted drive.
    – Roland
    Apr 29, 2013 at 10:12

1 Answer 1


I think the problem with iocharset. Try to specify iocharset -o iocharset=utf8,nounix

mount -t cifs //<IP>/path/to/folder /mnt/temp -o iocharset=utf8,username=Guest,passwd="guest",nounix

Also there is AutoFS utility.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .