2

I run a KVM Ubuntu 20.04 LTS guest. My host is Ubuntu 22.04 LTS. Virtual Machine Manager is 4.0.0.

The guest doesn't grab the SUPER key or the ALT+TAB keys, so even in full screen mode, both SUPER and ALT+TAB do their thing on the HOST, making it impossible for me to navigate between windows inside the guess without the use of the mouse.

Everyone asks for help to return the focus to the HOST, but in my case I need help the other way around: work inside the GUEST full screen and be able to do ALT+TAB between the apps running inside the guess.

I've read some pages about a "Force grab" checkbox in the Console tab of Virtual Machine Manager's preferences. But mine has no such a checkbox, as shown in the following screen capture:

enter image description here

1 Answer 1

0

I solved this issue by clicking the cog-like button in the lower right corner of Ubuntu's login screen, and choosing "Ubuntu on Xorg". The default option is simply "Ubuntu", which uses Wayland. It seems KVM doesn't fully support Wayland yet.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .