I have a desktop PC with a HDMI monitor connected to a nvidia GeForce GT 1030 and a second VGA monitor connected to an integrated Intel UHD Graphics 630.

Both monitors have worked smoothly for years with Ubuntu 18.04

I recently installed Lubuntu 22.04 on the same PC and both monitors were automatically activated without problems.

But now, in Debian 11 (with LXQt desktop) the HDMI monitor is the only one that turns on. The VGA monitor only displays text at boot and then goes in to sleep mode.

On Debian lspci says everything is allright:

root@debian:/home/cesar# lspci -k | grep -EA3 'VGA|3D|Display'
00:02.0 Display controller: Intel Corporation CometLake-S GT2 [UHD Graphics 630]
        DeviceName: Onboard - Video
        Subsystem: Gigabyte Technology Co., Ltd UHD Graphics 630 (Desktop)
        Kernel driver in use: i915
01:00.0 VGA compatible controller: NVIDIA Corporation GP108 [GeForce GT 1030] (rev a1)
        Subsystem: Gigabyte Technology Co., Ltd GP108 [GeForce GT 1030]
        Kernel driver in use: nvidia
        Kernel modules: nvidia

And for xrandr there's no error message either, but the Intel integrated graphics card simply doesn't exist:

root@debian:/home/cesar# xrandr
Screen 0: minimum 8 x 8, current 1366 x 768, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 410mm x 230mm
   1366x768      59.79*+
   1280x720      60.00    59.94    50.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93

Please give me some suggestions on where to keep looking. I've tried several proposals, but none has worked so far

  • @Peregrino69 I've tried both controllers nvidia and noveau. The same result, the VGA monitor receives no signal from Debian Commented Mar 6, 2023 at 21:27
  • @Peregrino69 It's not a hardware problem because I have Lubuntu and Debian installed with dual boot. With Lubuntu everything works automatically. Not with Debian. Commented Mar 6, 2023 at 21:29
  • Nvidia.... Bad news. It will not work. I tried it with similar situation (old nvidia cards + four monitor, centos 7->Mint 21, partial success => new hardware), a lot of effort for nothing. You need to use the old X system, or forget the old nvidia cards.
    – K-attila-
    Commented Mar 7, 2023 at 9:07
  • @K-att- Exactly the same configuration, with the same nvidia card works right now with Lubuntu 22.04. So it's not hardware problem Commented Mar 7, 2023 at 10:08
  • Yes, it is not a hardware problem. It's based on the old binary driver and the new X windows system. That's why Linus told to Nvidia........ You know, what.
    – K-attila-
    Commented Mar 7, 2023 at 12:10

1 Answer 1


The solution was easy (very hard to find, very easy to implement), thanks to: https://askubuntu.com/a/821031/638413

The technical explanation is here.

My case was even easier, I didn't need to create the xorg.conf file.

Here are the steps I followed:

  • Install the nvidia driver according to the instructions here.

  • In the user account, create the xsessionrc file:

    vi ~/.xsessionrc

    With the following content:

    xrandr --setprovideroutputsource modesetting NVIDIA-0
    xrandr --auto

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .