I have been running virtualbox on an Ubuntu 12.04 laptop for a while and it has all worked smooth, but suddenly, probably after a kernel upgrade, the vbox* modules are not loading at boot, if I manually modprobe them, it all works fine, but that should not be needed ...

Looking at the /etc/init.d/virtualbox, it seems as I should add LOAD_VBOXDRV_MODULE=1 to /etc/default/virtualbox, but for other machines it works without that line...

Any clues?

  • You using the latest version of virtual box?
    – slm
    Apr 27, 2013 at 8:59
  • Why don't you just set the option in the config file
    – daisy
    Apr 27, 2013 at 9:29

1 Answer 1


Sounds like this computer is running an older version of Virtual Box. The environment variable, LOAD_VBOXDRV_MODULE is only needed in an obsolete version of VB: VirtualBox Open Source Edition (i.e. OSE).

That variable was used to control the loading of the VB OSE kernel modules. Setting it to a 0 made them not load, setting it to a 1 made them load... which is your issue.

The fact that the modprobe resolves your issue I think proves my point.


  • Thanks, I'll look into that. The strange thing is that it worked fine, and then suddenly died. a few colleagues of mine has the same setup without any problems. Apr 27, 2013 at 21:15
  • vboxmanage --version 4.1.12_Ubuntur77245 Apr 27, 2013 at 21:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .