0

I installed docker rootless with dockerd-rootless-setuptool.sh install to rhel 7.9. The info of the output is below.

[INFO] systemd not detected, dockerd-rootless.sh needs to be started manually:

When I try to start the service with systemctl --user start docker as it is described in the documentation, it failed with error Failed to get D-Bus connection: No such file or directory. I read some of the posts in here and to debug the situation, I enabled lingering of the mentioned user. I can see the file at the path ll /var/lib/systemd/linger. After that, when I run systemctl --user command, again the Failed Dbus connection error occurs. I can list my user after enabling linger with the loginctl list-users, but when I run ps -fu dockeruser, the output didn't show /usr/lib/systemd --user as it suppose to be. The output is below.

ps -fu dockeruser
UID         PID   PPID  C STIME TTY          TIME CMD
dockeru+  45222  45220  0 10:58 ?        00:00:00 sshd: dockeruser@pts/0
dockeru+  45225  45222  0 10:58 pts/0    00:00:00 -bash
dockeru+  45254  45223  0 10:58 ?        00:00:00 sshd: dockeruser@notty
dockeru+  45255  45254  0 10:58 ?        00:00:00 /usr/libexec/openssh/sftp-server
dockeru+  47264  45222  0 11:10 ?        00:00:00 bash -c while [ -d /proc/$PPID ]; do sleep 1;head -v -n 8 /proc/meminfo; head -v -n 2 /proc/s
dockeru+  50009  47264  0 11:18 ?        00:00:00 sleep 1
dockeru+  50010  45225  0 11:18 pts/0    00:00:00 ps -fu dockeruser

I use ssh to login to the server. My dockeruser's bashrc is set as docker installation required.

#User specific aliases and functions
export XDG_RUNTIME_DIR=/home/dockeruser/.docker/run
export PATH=/bin:$PATH
# Some applications may require the following environment variable too:
export DOCKER_HOST=unix:///home/dockeruser/.docker/run/docker.sock

Also in documentation it is referred that The systemd unit file is installed as ~/.config/systemd/user/docker.service. When I checked that file, I found out that it is missing. Maybe the setuptool is problematic or sth?

2
  • Does this help? Commented Feb 24, 2023 at 13:37
  • @EdgarMagallon I followed that post before writing my own but it didn't work for me.
    – G.Baysec
    Commented Mar 2, 2023 at 15:51

1 Answer 1

0

Workaround solution: use rhel 8.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .