1

Hi guys I am new to arch just installed it on my machine have not rebooted yet, accessing it via arch-chroot /mnt. I have installed the iwd package and when running the iwctl it is showing -

"Waiting for IWD to start..."

Screenshot - enter image description here

And that's it, I am following this guide here and have fully installed the system just not rebooted yet because last time I did, it did not had IWD package installed so there was no way to connect to internet.

Also I tried using nmcli d but it did not showed my device. I tried looking for solution online it was mentioned to install linux-firmware package here.

I will be in chroot until I get a solution, I hope I made it clear so please make it quick guys, Thanks.

2 Answers 2

1

what happens when you do

sudo systemctl start iwd

also you will need to have the iwd package installed so that when u boot you have access to iwctl

if that does not work try this

sudo systemctl enable --now systemd-networkd systemd-resolved iwd
networkctl status -a
------------------------------------------------------------------
sudo nvim /etc/systemd/network/20-wireless.network     [Match]
                                                       Name=wlan0
                             
                                                       [Network]
                                                       DHCP=yes        
sudo systemctl restart systemd-networkd
------------------------------------------------------------------
iwctl
[iwd]# station wlan0 connect mywifiname
[iwd]# exit
networkctl status -a
2
  • Welcome to U&L. While your answer might be correct, you should edit it to add the steps from the link. This is to preserve the information. If the link target disappears for whatever reason, this answer will be useless. This is why link-only answers are usually deleted. You'll find good advise for writing a good answer in the Help. Feb 24, 2023 at 8:18
  • yeah that makes sense I will update it Feb 24, 2023 at 8:19
1

Solution

  • Make sure to install linux-firmware and base during installation of linux kernel

    pacstrap /mnt linux-firmware base

  • Install networking tools before rebooting your system -

pacman -S networkmanager network-manager-applet dialog wireless_tools
 wpa_supplicant os-prober base-devel linux-headers
  • After reboot type command nmtui, select your network and enjoy

Thanks for the attention to my problem, I have solved the issue and have fully installed and working arch on my machine. Actually I deleted the partition and installed arch again, maybe several times and then I finally had working arch setup, it was my first install and I was lazy to read every single article fully till the end for the solution, so please read the articles and follow the installation wiki attentively and for sure you will have the system up and running.

In this case I decided to not to proceed with iwd I think in my installation it needed some further configuration, I think network manager is a better choice for beginners. Thanks for all the answers I really appreciate it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .