1

I recently installed Linux Mint 13 alongside windows 7. I have a Realtek RTL8191SEvB Wireless Card. This work's fine with any router. However when I try to connect to a Belkin G Wireless Router it constantly says the passwords or encryption type are incorrect. They are not. I can connect to the Belkin router when I start my laptop (a toshiba satelite) with windows. Any ideas?

  • Check if there is any difference between cryptography algorithms used by the different routers (e.g. WEP, WPA-TKIP, WPA2-TKIP, WPA2-AES). – andcoz Apr 25 '13 at 11:33
  • Its WPA 2. Every other computer in the house can connect to it using that setting... – user1716672 Apr 25 '13 at 11:40
1

When you say you installed it alongside windows do you mean that you are dual booting windows and mint? Or are you running a virtual instance within windows?

Either way try this from the command line:

ifconfig wlan0 up && iwlist wlan0 scan | egrep -i "ssid|cipher"

If you get some kind of error check to see if you even have a wlan0 config file in your network-scripts folder. You can omit the pipe to egrep if you want a bunch of irrelevant info. Then do:

 iwconfig wlan0 essid "your network name goes here" key s:"your wireless password"
 dhclient wlan0
  • I tried the first command and I got: – user1716672 May 2 '13 at 10:20
  • I tried the first command and I got: ESSID: "my network name" Group Cipher : TKIP Pairwise Cipher (1) : CCMP Group Cipher : TKIP Pairwise Ciphers (2) : TKIP CCMP. I think iwconfig does not support WPA only WEP.... – user1716672 May 2 '13 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.