1

I am trying to set up proxies on my Red Hat Enterprise Linux 9. I am trying to install CNTLM proxy authentication software. I downloaded the RPM file from the official repo and tried the following command:

sudo rpm -Uvh cntlm-0.92.3-1.x86_64.rpm

However, I get

error: Failed dependencies:
        /sbin/chkconfig is needed by cntlm-0.92.3-1.x86_64

To try to fix this, I used the following command:

sudo dnf install chkconfig

This had the following output:

Updating Subscription Management repositories.
Icinga RH9                                      3.7 kB/s | 2.0 kB     00:00
rh9-bosch                                       3.7 kB/s | 2.0 kB     00:00
Dependencies resolved.
================================================================================
 Package      Arch      Version          Repository                        Size
================================================================================
Installing:
 chkconfig    x86_64    1.20-2.el9       rhel-9-for-x86_64-baseos-rpms    184 k

Transaction Summary
================================================================================
Install  1 Package

Total download size: 184 k
Installed size: 764 k
Is this ok [y/N]: y
Downloading Packages:
chkconfig-1.20-2.el9.x86_64.rpm                 177 kB/s | 184 kB     00:01
--------------------------------------------------------------------------------
Total                                           177 kB/s | 184 kB     00:01
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1
  Installing       : chkconfig-1.20-2.el9.x86_64                            1/1
Error unpacking rpm package chkconfig-1.20-2.el9.x86_64
  Verifying        : chkconfig-1.20-2.el9.x86_64                            1/1
Installed products updated.

Failed:
  chkconfig-1.20-2.el9.x86_64

First off, the "error unpacking rpm..." error message and the "Installed products updated" messages seem contradictory; I don't understand exactly what's going on there. Secondly, this appears to make no difference - I'm still unable to do the cntlm install.

Can anyone suggest how I can fix this so that I can install cntlm?

4
  • I would be suspicious of anything that wants chkconfig, since that hasn't been regularly used since RHEL 6. It's used to manage sys-v style init scripts, while RHEL 7 and later use systemd. There's probably some compatability shims in place so that it works, but it it seems janky.
    – larsks
    Commented Feb 22, 2023 at 3:04
  • I just checked, and it looks like the package you're trying to install is over 10 years old. I would be surprised if it works at all!
    – larsks
    Commented Feb 22, 2023 at 3:06
  • @larsks Yeah, I did notice that too; I did a cursory search for a replacement but haven't found a good one yet, maybe I need to look a little harder (unless you're aware of a good replacement). Commented Feb 22, 2023 at 15:27
  • @larsks I probably just made it obvious that I'm very new to RHEL :) That's good feedback, thanks. Commented Feb 22, 2023 at 15:29

1 Answer 1

1
  • To install chckconfig, check if you have /etc/init.d Directory, if yes take a backup by moving it to /tmp.

  • Then try installing chckconfig again.

  • This worked for me and is been mentioned in the RedHat solutions page.

https://access.redhat.com/solutions/6969215

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .