1

After installing pgAdmin4 with sudo pacman -Sy pgadmin, when I try running it, it gets stuck on the starting screen:

Starting Screen of pgAdmin

It doesn't even close visually (xorg), I need to do it with killall pgAdmin4. The error log I get is this, when launching from the terminal:

QCoreApplication::applicationFilePath: Please instantiate the QApplication object first
QCoreApplication::applicationFilePath: Please instantiate the QApplication object first
Semaphore name: "pgadmin4-philippe-a59283b86ae8ae85d20fdf770d799dd7-sema"
Shared memory segment name: "pgadmin4-philippe-a59283b86ae8ae85d20fdf770d799dd7-shmem"
Python path:  "/usr/lib/python3.10:/usr/lib/python3.10/lib-dynload:/usr/lib/python3.10/site-packages"
Python Home:  "/usr/lib/python3.10"
Webapp path:  "/usr/lib/pgadmin4/web/pgAdmin4.py"
^C"An error occurred initialising the pgAdmin 4 server:\n\nFailed to launch the application server, server thread exiting."

enter image description here

I've also tried to install it through pip, but it's the same thing. Right now, I'm using a containerized image of pgAdmin4.

1
  • BTW, removing Qt from tag & title since it is in no way involved.
    – MC68020
    Feb 22, 2023 at 6:53

1 Answer 1

1

I read about this problem some times ago in gentoo bugzilla

As you can read, the culprit was identified as being API breaking flask-security > 3.4.5

So, for some time, the problem went worked around by forcing dependencies to :

  • flask-security < 4
  • flask < 2

When it became difficult to maintain those deprecated versions… gentoo devs incidentally removed pagAdmin4 from the repo.

I cannot tell regarding Arch repo. But, provided flask-security and flask still exist in those old versions AND you have made sure that no other package you installed depend on higher versions then… you could try downgrading.

1
  • Or maybe downgrade to pgAdmin3?
    – psygo
    Feb 22, 2023 at 19:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .