1

I'm running a CentOS 7 VMWare machine Everytime I open the Terminal Cinnamon crashes and goes to fallback mode and needs to be restarted.

When I run dmesg after it crashes this line appears:

cinnamon[51356]: segfault at c0 ip 00007f2e66f10b50 sp 00007fffc6f42be78 error 4 in libgio-2.0.so.0.5600.1[7f2e66e1e000+19600]

I have tried basically any other Solution to similar Questions of Cinnamon crashing and none of them helped. I also tried reinstalling all the Cinnamon and GNOME libraries and their dependencies and nothing worked for me so I'm pretty lost now. Any help would be highly appreciated.

4
  • Can you install a different terminal and try to open it? I think you are trying with gnome-terminal bundled with cinnamon, and I am wondering if this is reproducible in another terminal software? (i.e. xterm or terminator)
    – Csnap
    Feb 20, 2023 at 17:42
  • Alternately, there have been known issues in the past regarding Cinnamon and "libgio", in case you have any kind of third-party applets installed: github.com/linuxmint/cinnamon/issues/2835
    – Csnap
    Feb 20, 2023 at 17:44
  • I tried I've known about the GitHub issue. however, it gets solved by disabling Applets which are already disabled on my machine
    – Noft
    Feb 21, 2023 at 7:38
  • I also tried to install a new terminal (I installed xfce, xterm, terminator, guake) and they all crashed as well. what's weird is that it happens only with any kind of terminal application. It doesn't occur with any other app.
    – Noft
    Feb 21, 2023 at 7:40

1 Answer 1

1

When a terminal opened .bashrc ran scripts that are located in /etc/profile.d and a few of them were made to create desktop shourtcuts for applications such as Pycharm, CLion etc..

The next command is what caused the crashes:

echo "
[Desktop Entry]
<Shortcut Configurations>
" | tee ~/Desktop/APP.desktop > ~/.local/share/applications/APP.desktop

I just removed the scripts that contained the same type of command from /etc/profile.d and it solved the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .