0

I have now tried about 20 times to install Qubes (on a Windows 11) system, and no matter what I try I keep hitting a brick wall incredibly early in the process. I can't even get to the Qubes installer proper, which I understand has a pretty logo and everything and is supposed to show up just to even really start the partitioning and installation process.

Instead I just get a blank screen almost immediately!

  • If I choose the normal installation option from the GRUB2 menu, I get a blank screen immediately (though sometimes with an underscore cursor at top left).
  • If I choose the troubleshooting/verbose installation option from the GRUB2 menu, I see a few pages of output text, then the text all disappears (in a strange top-to-bottom wipe effect) IMPORTANT LATE EDIT (WHOOPS!): The last line seen is "(XEN) Xen is relinquishing VGA console."

Either way I can't accomplish anything at that point other than powering off the computer (and once again contemplating giving up on Qubes). In a few of the 10 or so instances during which I was using a USB flash drive with a drive access light, that light continued to flash, but I've let it run for a good 15 minutes before and nothing else happened.

My most basic attempt at installing Qubes was setting up a 128-GB USB flash drive with Qubes-R4.1.1-x86_64.iso using Rufus, with the GPT and UEFI options, in ISO/hybrid mode.

Here are the many and varied workarounds I remember trying so far, based on everything I've been able to find online on this issue:

  • Setting up USB flash drive using Rufus in DD mode instead of ISO mode
  • Using a different USB flash drive (in case there was something wrong with the first drive)
  • Setting up USB flash drive using Easy2Boot, and dropping the ISO into that
  • Setting up USB flash drive using Easy2Boot, using the Easy2Boot MPI_FAT32 file conversion utility to convert the ISO (to DD mode? I don't remember now. It was one of the earlier attempts), then dropping the converted file into the Easy2Boot drive
  • Setting up a USB flash drive using Ventoy, and putting Qubes-R4.1.1-x86_64.iso on that
  • Trying another Linux distro ISO, on the same drive as the Qubes ISO (on that Ventoy (multi-boot) drive) and verifying the other distro launched with no problems
  • In BIOS, verifying Secure Boot disabled (this was the default setting)
  • In BIOS, trying to switch from UEFI to MBR/legacy or CSM mode (but not seeing that either of those other modes is possible with my BIOS). (I did read a little on flashing in a new BIOS, but I really don't feel like going down that road unless I know it will work and I know it is the only way to make this work)
  • Some other BIOS settings changes I don't remember the details of at this point
  • Using Qubes-4.1.20221231-kernel-latest-x86_64.iso (from https://qubes.notset.fr/iso/) (since fairly new hardware might only work with a fairly new kernel)
  • Using a third USB flash drive, this time an 8-GB drive (since I heard in some cases the maximum drive size the system can read could be 8 GB) (and on that drive trying all four (non-multiboot) set-up combinations (Rufus ISO/hybrid mode and DD mode, basic ISO and latest kernel ISO))
  • At the blank screen, pressing every possible combination of modifier key and F-key ([F1], [Shift]+[F1], [Ctrl]+[F1], [Alt]+[F1], [Shift]+[Ctrl]+[F1], [Shift]+[Alt]+[F1], [Ctrl]+[Alt]+[F1], [Shift]+[Ctrl]+[Alt]+{Fi], [F2}, ...), since I heard you can sometimes get some kind of CLI prompt that way

Please help. This is crazymaking. At this point I've loaded my Ventoy drive up with many other Linux distribution ISOs, and maybe the only reason I'm still giving Qubes a chance is because I haven't settled on a second choice of distro yet!

I did come across yet another tactic, which was changing some configuration variable values, either in the ISO or live during the install. I haven't tried that, though, because (for the ISO editing route) I don't know how to edit an .iso file, and (for the live variable setting route) I don't know how to interrupt things (even in the 10 luxurious seconds I would have in verbose mode before the screen goes blank) and live-edit those variables and resume things.

(Note: I'm using the 'Linux' tag here because I don't know if this is an issue with just the Qubes distribution or with other distros as well, even though I have had success with one other distro.)

3 Answers 3

1

Another kind of solution.

  1. Prepare a hard disk partition for goal Qubes installation.
  2. Attach the hard disk to another computer.
  3. Install Qubes there.

If that installation is not starts on the target computer. Boot on any live USB and make appropriate changes in /etc/fstab settings. I hope you understand how it works.

2
  • I'm upvoting this because it seems like it could work. In my case, though, I really don't want to crack open my laptop and swap the drive out and back in just to solve something that seems very much like it should be able to be solved with software. Really looking for a keyboard incantation here.
    – A.M.
    Commented Feb 17, 2023 at 2:57
  • Try an external drive. Commented Feb 17, 2023 at 19:34
0

Qubes-20221001-kernel-latest-x86_64.iso Is OK! https://qubes.notset.fr/iso/

3
  • Were you able to reproduce my issue using Qubes-R4.1.1-x86_64.iso or Qubes-4.1.20221231-kernel-latest-x86_64.iso? Presumably those are also OK for some people, but they just aren't working for others, and unless you get the black screen error with the ISOs I've tried I would assume you're just in the first camp.
    – A.M.
    Commented Feb 9, 2023 at 16:33
  • I'll guess I'll try that even older ISO anyway, but I don't see how an older kernel could help. I also don't understand why the Qubes version number is missing in the older ISOs such as the one you're recommending.
    – A.M.
    Commented Feb 9, 2023 at 16:36
  • Thank you for the idea. I just tried booting from the ISO you mentioned (twice, with the drive set up in ISO/hybrid and DD modes) and got the same black screen, though.
    – A.M.
    Commented Feb 9, 2023 at 23:32
0

It most likely you are in trouble with video driver.

  1. Having GRUB2 you can play with kernel parameters. Read all of them and think how they could help in your case. At least you have video, drm.edid_firmware, vga to play with. Also you can turn on verbose kernel output via the user_debug param. It might help you figure out the issue deeper.
  2. Try to search and play with video settings in XEN if they have such settings.
  3. Install earlier Qubes release and upgrade it after. I hope it have such option like Debian.
5
  • I took a look at that kernel parameter list, and wow it's long. I've tried to install the latest version of Qubes, but also two other versions, including an older one, already. I like the idea of playing with video settings (in Xen, sure), but I don't know how to do that, especially in the middle of an installer running. I think I would need the answer to this question to do that: unix.stackexchange.com/questions/735177/…
    – A.M.
    Commented Feb 13, 2023 at 20:19
  • Please note, you should play with kernel settings before installer starting. In case of GRUB2. Once menu appears you are to tap the 'e' letter and see the GRUB menu point settings which could be edited. I don't think it is a good idea in your link. May be better to change virtual machine. VirtualBox instead of XEN and so on. Commented Feb 14, 2023 at 22:41
  • I did something like that (I don't remember if it was the 'e' key I pressed, or if it was some other key), but I didn't see very many options at all, and certainly nothing that made it sound like I could change a variable value. If you have info on how to do that, by all means add an answer to that question.
    – A.M.
    Commented Feb 17, 2023 at 2:49
  • I would absolutely accept this answer if it showed what parameter to change and how to do so. As it is, though, maybe it would nudge some people in the correct direction, but I don't know what to do with this info.
    – A.M.
    Commented Feb 17, 2023 at 2:52
  • In such cases I read them all and think about any of them how it would help to me. But it is ok if you consider this work too hard. Commented Feb 17, 2023 at 19:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .