0

https://i.sstatic.net/d1REs.png

Trying to install Linux Mint to dual-boot with Windows 11 I always get the above error. I`m not sure what is wrong, drive works perfectly on Windows and when I format it to ntfs, fat32, ext2, etc... it works perfectly as well. I cannot mount it either. The device I want to install it to is /dev/sda, a SSD of 250gb and my installation device is a 16gb pen-drive.

fdisk -l yields:

root@mint:/home/mint# fdisk -l
Disk /dev/loop0: 2.34 GiB, 2515390464 bytes, 4912872 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/nvme0n1: 238.47 GiB, 256060514304 bytes, 500118192 sectors
Disk model: SSSTC CL1-4D256                         
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 5AEAC324-E073-45E4-A1E5-7FFB0E9C35DB

Device             Start       End   Sectors   Size Type
/dev/nvme0n1p1      2048    534527    532480   260M EFI System
/dev/nvme0n1p2    534528    567295     32768    16M Microsoft reserved
/dev/nvme0n1p3    567296 498065776 497498481 237.2G Microsoft basic data
/dev/nvme0n1p4 498069504 500117503   2048000  1000M Windows recovery environment


Disk /dev/sdb: 14.32 GiB, 15376318464 bytes, 30031872 sectors
Disk model: Cruzer Blade    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 07896644-3E61-4841-B41A-CA3F44823CCE

Device       Start      End  Sectors  Size Type
/dev/sdb1       64  5228883  5228820  2.5G Microsoft basic data
/dev/sdb2  5228884  5237379     8496  4.1M EFI System
/dev/sdb3  5238784 30031808 24793025 11.8G Linux filesystem
The backup GPT table is corrupt, but the primary appears OK, so that will be used.


Disk /dev/sda: 234.38 GiB, 251658240000 bytes, 491520000 sectors
Disk model: SD/MMC/MS PRO   
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 1D9ED2E0-08EC-4B50-BA77-FDDE180000F0

Device       Start       End   Sectors   Size Type
/dev/sda1     2048   1050623   1048576   512M EFI System
/dev/sda2  1050624 491517951 490467328 233.9G Linux filesystem

After doing mkdir.ext4 on /dev/sda:

root@mint:/home/mint# mkfs.ext4 /dev/sda
mke2fs 1.46.5 (30-Dec-2021)
Found a gpt partition table in /dev/sda
Proceed anyway? (y,N) y
Creating filesystem with 61440000 4k blocks and 15360000 inodes
Filesystem UUID: 72493794-1b54-4809-9d60-d28eff016d6a
Superblock backups stored on blocks: 
    32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 
    4096000, 7962624, 11239424, 20480000, 23887872

Allocating group tables: done                            
Writing inode tables: done                            
Creating journal (262144 blocks): done
Writing superblocks and filesystem accounting information: done

I thought this would have fixed it but now it gave me

    root@mint:/home/mint# gdisk /dev/sda
GPT fdisk (gdisk) version 1.0.8

Caution: invalid backup GPT header, but valid main header; regenerating
backup header from main header.

Warning! One or more CRCs don't match. You should repair the disk!
Main header: OK
Backup header: ERROR
Main partition table: OK
Backup partition table: OK

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: damaged

****************************************************************************
Caution: Found protective or hybrid MBR and corrupt GPT. Using GPT, but disk
verification and recovery are STRONGLY recommended.
****************************************************************************
10
  • Welcome to the community. The last line looks like you were intending to give more info? If yes, you can Edit your post to add the rest. Commented Feb 8, 2023 at 0:00
  • Oh well, i've tried a couple more times to no avail. I'll log-in tomorrow and post some edits, sorry... Commented Feb 8, 2023 at 1:10
  • As usual, when dual-booting with Windows disabling its Fast Startup feature is a must. So, start by doing that and shutting down Windows properly to make the setting stick. Then keep in mind you don't need and almost never there's a reason for more than one ESP (EFI System Partition); this mistake is visible on the results. When you don't know exactly what you're doing it's better to start with clean GPT drive (or enough unnalocated space if installing in the same drive) and use the automatic installation. Commented Feb 8, 2023 at 13:45
  • Where can i disable that? I disabled secure boot on bios settings but that didnt change anything. I tried formatting the disk on windows but that didnt work either. Is there some way to clean the drive completely? I dont mind losing data (theres nothing in it). Commented Feb 8, 2023 at 15:11
  • Also, heres another example of the error= (The attempt to mount a file system with type ext4 in SCSI1 (0,0,0), partition #2 (sda) at / failed. You may resume partitioning from the partitioning menu.) Commented Feb 8, 2023 at 15:13

1 Answer 1

0

By running mkfs.ext4 /dev/sda you created a filesystem on the disk, not on your target partition. You might want to start from scratch by creating a new empty GUID partition table on dev/sda:

  • Run gdisk /dev/sda
  • press o to create a new empty GUID partition table
  • press w to write the changes to the disk

The Mint installer should detect your empty disk and allow you to create and format the necessary partitions.

20
  • Should i format the disk first? Gparted seems to corrupt it when creating the ext4 file system. Also, i had the same problem trying that... Commented Feb 8, 2023 at 15:53
  • You can create the partitions beforehand (if you like gparted more) and then select the partitions in the installer, but that's not necessary.
    – Freddy
    Commented Feb 8, 2023 at 15:57
  • Did not work, it seems the GPT table becomes corrupted after trying to install, gdisk (before installation) says its fine but after it says its damaged. Commented Feb 8, 2023 at 15:58
  • It says SD/MMC/MS PRO in your fdisk output. It could be that the card is corrupted. Do you have a spare card to test?
    – Freddy
    Commented Feb 8, 2023 at 16:03
  • Well, i did try another sd card but it gives the same problem, and if it was corrupted it wouldnt work on windows right? Commented Feb 8, 2023 at 16:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .