0

I know, there's a similar question with the problem manifesting in a similar way but using virsh didn't work for me, it refused to delete the problematic VM.

I tried deleting all the configs to stop gnome-boxes from trying to load a faulty VM list but it didn't work. I deleted everything named gnome-boxes* in my home directory and apt purgeing it then reinstalling, the problem persisted.

2 Answers 2

0

I resolved the issue by deleting $HOME/.config/libvirt. I didn't notice any negative side effects with that (although it's probably better to delete/edit the problematic file therein, but I don't know which one) and now gnome-boxes works again flawlessly.

0

I also experienced the issue of gnome-boxes crashing at launch after an interrupted cloning of a virtual machine.

What worked for me on Ubuntu 22.04

Install virsh

sudo apt install libvirt-clients

List the machines

virsh -c qemu:///session list --all

Undefine the problematic machine

virsh -c qemu:///session undefine <machine-name-here>
1
  • 1
    As I wrote in the question, using virsh didn't work for me because it refused to undefine the VM, I have found that exact solution several times already out there.
    – Lampe2020
    Apr 10, 2023 at 21:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .