1

I am running 3 x Win11 and 1 x Win10 all with Office 365 Outlook. 3 of the Outlook clients connect to a postfix/dovecot server just fine on my home NAT, and can tunnel through my router from the outside as well.

The latest one, which is a replacement for a flaky laptop, can't establish a connection, and the /var/log/mail log shows the following error, stating the NETBIOS host name (visible on windows with the hostname command) and the sender and recipient emails.

NOQUEUE: reject: Helo command rejected: need fully-qualified hostname

Other references in Stack Exchange to this type of problem suggest changing the server to be more permissive. However, as 3 clients work there must be something I can do on the client side. I have set up the mail account in exactly the same way, using STARTTLS on ports 143 and 587. The log files are identical (other than things that normally change from one connection to the next) up to when this error occurs. I am using the email account configuration in Control Panel rather than Outlook to set up the connection as the latter does not allow the username to be anything other than the email address. That is what has worked in the past.

In all the research I've done I've not seen any suggestion on how to force Outlook to send a fully-qualified hostname, but I presume that it is possible as 3 of my Windows computers do, and one does not. The issue does not seem to be in the account setup, but somewhere else within Windows.

The server is Raspberry Pi OS. My LAN sits behind a DSL router with ports 25, 143 and 587 open. The client systems on the LAN receive their network address, name and domain name from dnsmasq. My wife's Win 10 laptop and my Android phone also have no trouble accessing mail over the LAN or from elsewhere.

1 Answer 1

0

The above message was a red herring.

The solution was to use the "Advanced Settings" -> "Outgoing Server" tab and check the "My outgoing server (SMTP) requires authentication" and retain the default "Use same settings as my incoming mail server".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .