1

What is the cause of the error ”Journal header limits reached or header out-of-date, rotating” and what can be done to fix it?

journalctl (systemd-journald[###]) reports journal errors:

Data hash table of /run/log/journal/####/system.journal has a fill level at 75.1 (3273 of 4359 items, 2510848 file size, 767 bytes per hash table item), suggesting rotation

and /run/log/journal/####/system.journal: Journal header limits reached or header out-of-date, rotating

Guest alma Linux 9.1 kernel 5.14.0-162.12.1.el9_1.x86_64 Fresh install, Media and Hash OK

Security Policy [DRAFT] DISA STIG for Red Hat Enterprise Linux 9

Hypervisor VirtualBox 7.0.6 r155176

df -h No Partition Use % above 30%

Host Windows 10 Pro 10.0.19044 Build 19044

Possibly Related

Chrony Time Sync Error on boot (no error on reboot, internet connection ok: occasional hang on connecting)

/etc/chrony.conf includes pool 2.almalinux.pool.ntp.org iburst maxpoll 16

server [0..3].rhel.pool.ntp.org iburst

There is ample disk space, time sync seems sufficient, the system is up to date, no new software has been installed.

0

1 Answer 1

4

Journal header limits reached or header out-of-date, rotating is not an error, it's an informational message.

It means systemd-journald adheres to the journal limit you've set.

5
  • It's a fresh install. I'm about to google setting limits. Thanks. Any more info equals MORE thanks :)
    – iletras
    Jan 31, 2023 at 1:57
  • I downvoted your answer by accident. When I noticed the error and tried to correct it, the edit window had closed. I asked the moderators to help me undo the mistake. They refused.
    – iletras
    Feb 4, 2023 at 23:00
  • 2
    Even if it's not an error, I would like to prevent it from spamming the console. It should not do this by default. Anyone know the cleanest way to suppress this message?
    – TyR
    Jun 9, 2023 at 22:17
  • @TyR this message mustn't appear in console by default, something's up with your systemd-journald settings. Maybe you've got ForwardToConsole or ForwardToWall enabled. Jun 9, 2023 at 23:12
  • 2
    @ArtemS.Tashkinov it appears that ForwardToWall=yes is the default on RHEL. Ideally this "Journal header limited reached" message would just not be logged to begin with, as that way I could keep ForwardToWall on, and generally have a clean console.
    – TyR
    Jun 10, 2023 at 22:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .