I'm running Debian Wheezy on a Asus P8Z68-V Pro/Gen3 mainboard. My graphics card is a Radeon 6850, I'm using the Open Source radeon drivers (xserver-xorg-video-radeon).

During boot, my screen occasionally stays black after boot menu selection. I cannot even switch to a terminal console. It freezes forever in that state.

Its really strange cause it only happens around half of the time and I cannot see any cause for this behavior. The other half of the times Debian boots successfully.


The Asus P8Z68-V Pro/Gen3 mainboard has an onboard graphics adapter.

When I attached a screen to the onboard adapter (which I usally don't use), I noticed that the screen was actually not staying blank, but Debian used the internal graphics to display a boot error - even when I set "Initiate Graphic Adapter" to PCIE/PCI instead of iGPU (internal).

I get two different errors, which also seems to be kind of random. Mostly I get this error:

Loading, please wait...
INIT: version 2.88 booting
[info] Using makefile-style concurrent boot in runlevel S.
[ ok ] Starting the hotplug events dispatcher: udevd.
[ ok ] Synthesizing the initial hotplug events...done.
[....] Waiting for /dev to be fully populated...[    3.964436] usb-6-1.7: firmware: agent aborted loading ath3k-1fw (not found?)
[    3.964561] Bluetooth: Error loading firmware

And sometimes it already freezes at Waiting for /dev to be fully populated.

I tried to disable the onboard bluetooth adapter, but I still got the black screen error from time to time.

Next I saw that the Bios allows to run both internal and external graphics together - the related setting is Advanced/System Agent Configuration/iGPU Multi-Monitor. I disabled that setting. Now I don't get the blank screen error anymore.

  • I could not find a better place where to post this problem (and its solution), but I just wanted it to be somewhere on the net, maybe it helps some poor guy out there with a similar configuration. Should I post this on any mailing list or something similar - could this info be useful to some developers? If yes, where should I post this? Apr 22 '13 at 21:39
  • Thanks a lot! This worked very well for me too. Approximately same setup but I'm using the properitary amd drivers. Oct 10 '13 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.