0

I cannot get my Virtual Box 7.0 "bridged adapter" to work on my laptop (Kubuntu 22.10). I have a project that I need to submit, but I cannot move forward until I fix this. This affects all my guest machines.

These are my guest virtual machines:

Guest Virtual Machines

  1. The 'Greenbone-Enterprise-TRAIL' virtual machine needs to be setup as 'bridge' because I am performing a vulnerability scan against another VM, 'analysis_image_final' which is an Ubuntu 14.04 virtual machine.

  2. Here is 'Greenbone-Enterprise' link of the website with instructions how to setup on VirtualBox >> enter link description here

  3. Below are the network settings on my Greenbone-Enterprise Trail on VirtualBox: GB Settings 'wlan0' is my wireless adapter.

GB Settings 2

Promiscuious mode picture below:

Promiscuious mode

I have tried researching previous articles but they didnt fix my issue:

  1. Virtualbox bridged adapter not working ubuntu
  2. VirtualBox Ubuntu 14.04 - Bridge adapter not working
  3. Kubuntu 16.10 - VirtualBox not working correctly

Then, I though maybe it's how my resolv.conf or netplan file setup

Here is my resolv.conf file below:

# This is /run/systemd/resolve/stub-resolv.conf managed by man:systemd-resolved(8).
# Do not edit.
#
# This file might be symlinked as /etc/resolv.conf. If you're looking at
# /etc/resolv.conf and seeing this text, you have followed the symlink.
#
# This is a dynamic resolv.conf file for connecting local clients to the
# internal DNS stub resolver of systemd-resolved. This file lists all
# configured search domains.
#
# Run "resolvectl status" to see details about the uplink DNS servers
# currently in use.
#
# Third party programs should typically not access this file directly, but only
# through the symlink at /etc/resolv.conf. To manage man:resolv.conf(5) in a
# different way, replace this symlink by a static file or a different symlink.
#
# See man:systemd-resolved.service(8) for details about the supported modes of
# operation for /etc/resolv.conf.

nameserver 127.0.0.53
options edns0 trust-ad
search .

Here is my 01-network-manager-all.yaml file below:

# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager

I found this article that I though this will fix my issue:

  1. How to set wlan0 active as default in /etc/network/interfaces?
  2. /etc/network/interfaces to connect Ubuntu to a wireless network

When I made changes to my resolv.conf file, my BIOS would not load my wireless adapter after reboot.

I need help

Update

output for nmcli connection show

nmcli connection show

2
  • Because you very likely don't have a bridge connection actually in place, please add output of nmcli connection show Jan 28, 2023 at 19:53
  • @NicolasFormichella updated the question with the output Jan 28, 2023 at 20:16

2 Answers 2

1

You will not be able to

Note that a bridge cannot be established over Wi-Fi networks operating in Ad-Hoc or Infrastructure modes. This is due to the IEEE 802.11 standard that specifies the use of 3-address frames in Wi-Fi for the efficient use of airtime.

From Red Hat support site

Solution : Get an Ethernet connection to that computer if practically possible, then follow the following guide and set bridged interface to whatever name you got it

1
0

I figured out the "My" solution!

Here is the link: How To Use Your Wireless Adapter With VirtualBox Bridge Mode

The bridged network adapter has its own MAC address (the hardware address of the card), although physically the bridged adapter is on the same card. The thing about network adapters is that they are not limited to a single IP address.

Also, a thing I wasn’t aware of is that the wifi authentication is in fact tied to the MAC address of the network card.

So once I figured this out, the solution at the outset I said it was fairly simple. Set the bridge network address to the mac address of the wireless adapter, then assign the Pfsense interface an ip address. And hey presto.. it works. Not a bad little bit of troubleshooting if I do say so myself.

For those who are newbies to IT, this image may help. This is the result of the ifconfig command in linux. The MAC address is highlighted. The same command can be used in Windows, although it is called ipconfig, and to see the MAC address, you have to use the command ipconfig /all.

pic1

As I have said, you take the highlighted address and put in in the virtual machine settings. Which are found under settings, which you can see in the next image. It’s a simple cut and paste, and you’re done.

pic2

This works for me

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .