I recently installed Lubuntu via a USB drive. It works great, but I have found one major problem. Upon booting up my laptop, it opens two one of two things.

The first is a Grub command line. If I simply type exit as a command, the laptop proceeds to a normal boot.

Sometimes, however, it will open up to the grub line, with an error message, saying it cannot find the kernel / the kernel is not defined. (I wish I could take screenshots but that is not an option for this problem.

I have tried changing the boot options in BIOS. I have tried a few suggested answers of setting the kernel proposed to similar questions. None of this has worked.

I assume this is an issue where I need to establish what my kernel is and have the machine boot from that. I don't know how though.

Overall my laptop works, and so it is not the most pressing issue, but I would like to fix it.

If anyone has any ideas on how to resolve this, I would be very grateful. Thanks! :)


Entered the command in the terminal sudo update-grub

Command succeeded.

Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Sourcing file `/etc/default/grub.d/lubuntu-grub-theme.cfg'
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/lubuntu-grub-theme/theme.txt
Found linux image: /boot/vmlinuz-5.19.0-29-generic
Found initrd image: /boot/initrd.img-5.19.0-29-generic
Found linux image: /boot/vmlinuz-5.19.0-21-generic
Found initrd image: /boot/initrd.img-5.19.0-21-generic
Memtest86+ needs a 16-bit boot, that is not available on EFI, exiting
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...

Rebooted the computer several times to see if the same issue was present. Issue is still present, described below.

The error on grub appears like:

error: command failed
error: you need to load the kernel first

This can be circumvented by pressing 'c', entering the original grub menu, and entering the 'exit' command

  • Run sudo update-grubfrom a successful boot, reboot and test. Please edit the question and describe what you already tried and the result of my suggestion. Jan 26 at 20:43
  • I ran the command. Rebooted the computer several times. Opened to grub twice and then to the previous error
    – Andylong
    Jan 26 at 20:58


You must log in to answer this question.

Browse other questions tagged .