0

Eve though in dconf the profiles i installed are shown

> dconf list /org/gnome/terminal/legacy/profiles:/

:3fab5042-3b59-44c2-b86e-df287109b3d7/
:93be6823-4719-4dea-be06-ebf0ae9091d8/
:Aci/
:Wild-cherry/
:b1dcc9dd-5262-4d8d-a863-c897e6d979b9/
default
list

In my terminal preferences they are not shown so that i can change the profile enter image description here

How can i resolve this issue, also i must say that i changed the curent value of profile in the dconf editor as another profile but still nothing in effect.

enter image description here

Also i must say that after i manually add profiles with the '+' button in the terminal preferences, if i add a new profile with "gogh" all the profiles i created manually are deleted, just the default profile left.

2 Answers 2

0

The list of available profiles is stored in /org/gnome/terminal/legacy/profiles:/list, and updated whenever you create or remove a profile using GNOME Terminal's Preferences panel.

(Don't ask me why it's stored under a separate key, rather than querying the list of subfolders. It might boil down to technical limitations of dconf or other possible backends behind gsettings, or legacy reasons, I'm not sure.)

8
  • Thank you for your answer, yes i have all my profiles in /org/gnome/terminal/legacy/profiles:/list but they are not in the preferences of the gnome-terminal so that i can change it. Profiles in that path doesn't show up in the preferences of terminal, this is my issue.
    – Deku
    Commented Jan 26, 2023 at 7:02
  • Just double checking that you're indeed also talking about an entry called list, rather than the listing? Does the output of dconf read /org/gnome/terminal/legacy/profiles:/list list them all? If so then it's interesting... what if you create a new profile from the terminal's preferences dialog? Does it appear there? Maybe the entire tree where the settings are taken from is different for you, you could do a recursive dconf dump / to locate where the newly created profile is stored, that could help?
    – egmont
    Commented Jan 26, 2023 at 11:33
  • Yes it does list all of profiles here is the output ['b1dcc9dd-5262-4d8d-a863-c897e6d979b9', '14a15cca-d3d1-45b5-9191-7434f9169437', 'Aci']
    – Deku
    Commented Jan 26, 2023 at 18:09
  • This really doesn't match the llisting in your original post. Also I'm wondering if IDs that don't match the UUID format are perhaps ignored, I don't know.
    – egmont
    Commented Jan 26, 2023 at 20:28
  • That is because i resetted my profiles and than tried again. But still as you can see the list property shows that i have 3 profiles one of them being Aci which i get with gogh, but none of them listed in the terminal preferences. And what is the needed format for profile uuid's maybe i can edit them. I edited and added some new information on the original post by the way.
    – Deku
    Commented Jan 27, 2023 at 15:01
0

Okay i found a solution. The problem was with the wrong uuid format like @egmont said. The solution was to export the profiles with dconf dump from another working machine and get the right uuid, than importing those profiles with dconf load. After that i just added those uuids in the /profiles:/list. Ant there was the profiles in the preferences. Thanks for all the replies

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .